summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-04 14:16:39 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-04 14:16:39 +0000
commit7189d10d778878e67eebd64284259fe5454929bf (patch)
tree0d74dd02a27d57867d66b209c11963d088bcc539 /dev-java/microba/microba-0.4.4.3.ebuild
parentdev-java/xpp3: EAPI 5 bump. Switch to java-pkg-simple. (diff)
downloadgentoo-7189d10d778878e67eebd64284259fe5454929bf.tar.gz
gentoo-7189d10d778878e67eebd64284259fe5454929bf.tar.bz2
gentoo-7189d10d778878e67eebd64284259fe5454929bf.zip
dev-java/microba: Version bump. EAPI 5 bump. Switch to java-pkg-simple.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/microba/microba-0.4.4.3.ebuild')
-rw-r--r--dev-java/microba/microba-0.4.4.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/microba/microba-0.4.4.3.ebuild b/dev-java/microba/microba-0.4.4.3.ebuild
new file mode 100644
index 000000000000..5c9945dcffc1
--- /dev/null
+++ b/dev-java/microba/microba-0.4.4.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Swing components for date operations and palettes"
+HOMEPAGE="https://github.com/tdbear/microba"
+SRC_URI="https://github.com/tdbear/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-java/jgraph:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="jgraph"
+
+JAVA_SRC_DIR="src"
+
+src_install() {
+ java-pkg-simple_src_install
+ mv change.log.txt CHANGELOG || die
+ mv readme.txt README || die
+ dodoc {README,CHANGELOG,README.md}
+}