summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-01 07:52:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-01 07:55:49 +0000
commitd85bd231377210c08d25015d5028ac913228d57b (patch)
treef4eea76e37c6e3d9f61e5187ddc42d7c080b3bb3 /dev-java/offo-hyphenation
parentdev-java/netty-transport: Clean up old build xml file. (diff)
downloadgentoo-d85bd231377210c08d25015d5028ac913228d57b.tar.gz
gentoo-d85bd231377210c08d25015d5028ac913228d57b.tar.bz2
gentoo-d85bd231377210c08d25015d5028ac913228d57b.zip
dev-java/offo-hyphenation: EAPI 5 bump. Version bump.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/offo-hyphenation')
-rw-r--r--dev-java/offo-hyphenation/Manifest1
-rw-r--r--dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/offo-hyphenation/Manifest b/dev-java/offo-hyphenation/Manifest
index 07c0ef95e269..35664011ca5b 100644
--- a/dev-java/offo-hyphenation/Manifest
+++ b/dev-java/offo-hyphenation/Manifest
@@ -1 +1,2 @@
DIST offo-hyphenation_v1.2.zip 378809 SHA256 026c3605416e921cdc5b24ba486fef306d1a4863ba95295f689b7190885e5c5a SHA512 ef0cb0aa7020bedd6c59f6d4cec95274f18fc5a7d19d24d1a05014c7c20b70c8e515aa7b7db4852a0c1bb87f594f638a906b5b61c0443804902cc9876d35d934 WHIRLPOOL 1a644a55a1769a866fa47e654310b942ef176396c3c2070c7b69f3e5e82e69156f42535363a127733753488bcddfee5b41b505ba512b4a0126f37fec96b6c98a
+DIST offo-hyphenation_v2.0.zip 858046 SHA256 79d341820583aa5b77ee00dc7da59bfafb92adceb88c7a1922fe300a90a22c4e SHA512 8a907a38dcb54ef1578973293efa2fcd771e3c77faedd537381f04f6f543b3f04ff8b8f96fb692274e9fe9cbdb2d3d8e5c7b29caae412271d9d8c023c079421b WHIRLPOOL 58e39e8caa8ef2dae2bdd715ceb8bd5a5b4c5879d61404558ebabeb4ee4256b6a1e0ee6932e0e81d6162bb65a8fbf8e70a5683df102851d764df3dfae98c1bb7
diff --git a/dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild b/dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild
new file mode 100644
index 000000000000..8056c5c91ddd
--- /dev/null
+++ b/dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Hyphenation patterns for Apache Fop"
+HOMEPAGE="http://offo.sourceforge.net"
+# upstream will hopefully version future release...
+SRC_URI="mirror://sourceforge/offo/${PN}_v${PV}.zip"
+# review this upon update!
+LICENSE="GPL-2 Apache-2.0 LPPL-1.3b TeX"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/${PN}/
+ insinto /usr/share/${PN}/
+ doins -r hyph
+
+ if use doc; then
+ dohtml -r images skin i*.html
+ fi
+}
+
+pkg_postinst() {
+ elog "This package installs hyphenation files for several languages"
+ elog "into /usr/share/${PN}/hyph"
+ elog "Check /usr/share/doc/${PF}/html/licenses.html for each file's license."
+ elog "To compile the patterns, install dev-java/fop with USE=hyphenation."
+ elog "Alternatively, use the uncompiled patterns via the <hyphenation-base>"
+ elog "configuration option. See the documentation for more details."
+}