summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-24 17:26:39 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-24 17:26:39 -0700
commitb0428dd5fd13b4a9b8ca437b5a66e4f157ef2da4 (patch)
tree3eb18423ff831971623adc0ca4e7b8ae6d8aa2f4 /dev-java/openjdk-jre-bin
parentdev-java/openjdk-bin: bump to 11.0.9_p11 (diff)
downloadgentoo-b0428dd5fd13b4a9b8ca437b5a66e4f157ef2da4.tar.gz
gentoo-b0428dd5fd13b4a9b8ca437b5a66e4f157ef2da4.tar.bz2
gentoo-b0428dd5fd13b4a9b8ca437b5a66e4f157ef2da4.zip
dev-java/openjdk-jre-bin: bump to 11.0.9_p11
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-java/openjdk-jre-bin')
-rw-r--r--dev-java/openjdk-jre-bin/Manifest1
-rw-r--r--dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.9_p11.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-java/openjdk-jre-bin/Manifest b/dev-java/openjdk-jre-bin/Manifest
index 4e8930ff1969..9b50b644b82b 100644
--- a/dev-java/openjdk-jre-bin/Manifest
+++ b/dev-java/openjdk-jre-bin/Manifest
@@ -1,3 +1,4 @@
DIST OpenJDK11U-jre_x64_linux_hotspot_11.0.8_10.tar.gz 42904191 BLAKE2B cfd04b2a422e95465cd2938449f7632d29fe655eadadf5745045db6eb74625dffa0e02d8713a93e0bc8fa7da6dc57116fbbd9217a9b30723becd5b9eaceefccd SHA512 55ab4c6122422f4765542df747bce5c65bc78e0e5f4fff4b7efc95342d81eb34d72dbdc13c820781c626f92a2c3687161d0c7edfbe4f83c455c75fcecf8ae3d0
+DIST OpenJDK11U-jre_x64_linux_hotspot_11.0.9_11.tar.gz 43086814 BLAKE2B 20785b5edb3fbfae99c7cdc76fba964a7a00eb148e68125138281c0995d6a82cfe9924c7f653dd188ab97da41135004546ec822bfa845f599135c8a9ec5e9336 SHA512 b0c53febc2628b91763cd5304cce782adaa71ff466c4dd9d056c7f1ac18e8f1f4ad2fc355882b2990fbd71e7792134697bcd1204eb9e03c12cf3b287ac33c3f0
DIST OpenJDK8U-jre_x64_linux_hotspot_8u265b01.tar.gz 41757024 BLAKE2B 39c184654dd5c4c17c617a48e962a392e3a4aaebe56a4286b6e5b0e980345b7260effbc54e2b197f8b747c57856e5260a048cf572cd4f375a2b38f3abebbde2f SHA512 01090a26bb18d226da19c82fca173f0d994ba56562178757347b565d39989b6735f5ff37bb22163c9ea270380fe922098bd0efa87d52615b50cde9f0e8291095
DIST OpenJDK8U-jre_x64_linux_hotspot_8u272b10.tar.gz 42139854 BLAKE2B 52e7a594aab1a70d351daf9dc42598b4952894a9a72ed996e261e347eece4337fe95c5f63850a0dde2d8862045d22ef41832a6af51df5113b81713bab20c797e SHA512 2fd45a9b967e96309c79724fea047d7c35f31da8e0290bd5cdafeea47b83941b9269129d0d557ee488526c0667ba581dee860381fc344374971e1005105db376
diff --git a/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.9_p11.ebuild b/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.9_p11.ebuild
new file mode 100644
index 000000000000..a6aade59d9e1
--- /dev/null
+++ b/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.9_p11.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2
+
+abi_uri() {
+ echo "${2-$1}? (
+ https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}U-jre_${1}_linux_hotspot_${MY_PV//+/_}.tar.gz
+ )"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+ $(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt Java JRE binaries provided by AdoptOpenJDK"
+HOMEPAGE="https://adoptopenjdk.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64"
+IUSE="alsa cups +gentoo-vm headless-awt selinux"
+
+RDEPEND="
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ >net-libs/libnet-1.1
+ >=sys-apps/baselayout-java-0.1.0-r1
+ >=sys-libs/glibc-2.2.5:*
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${MY_PV}-jre"
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED%/}/${dest#/}"
+
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
+
+ rm -v lib/security/cacerts || die
+ dosym ../../../../etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
+ dodir "${dest}"
+ cp -pPR * "${ddest}" || die
+
+ # provide stable symlink
+ dosym "${P}" "/opt/${PN}-${SLOT}"
+
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ java-vm_set-pax-markings "${ddest}"
+ java-vm_revdep-mask
+ java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+
+ if use gentoo-vm ; then
+ ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JRE"
+ ewarn "recognised by the system. This will almost certainly break things."
+ else
+ ewarn "The experimental gentoo-vm USE flag has not been enabled so this JRE"
+ ewarn "will not be recognised by the system. For example, simply calling"
+ ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+ ewarn "fully supports Java 11. This JRE must therefore be invoked using its"
+ ewarn "absolute location under ${EPREFIX}/opt/${P}."
+ fi
+}