summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/oscache/oscache-2.0.2-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/oscache/oscache-2.0.2-r3.ebuild')
-rw-r--r--dev-java/oscache/oscache-2.0.2-r3.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-java/oscache/oscache-2.0.2-r3.ebuild b/dev-java/oscache/oscache-2.0.2-r3.ebuild
new file mode 100644
index 000000000000..f2d852cf605a
--- /dev/null
+++ b/dev-java/oscache/oscache-2.0.2-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2
+
+DESCRIPTION="OSCache is a widely used, high performance J2EE caching framework"
+SRC_URI="https://oscache.dev.java.net/files/documents/629/2653/${P}-full.zip"
+HOMEPAGE="http://www.opensymphony.com/oscache/"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+COMMON_DEP="
+ dev-java/commons-collections
+ dev-java/commons-logging
+ java-virtuals/servlet-api:2.3
+ java-virtuals/jms
+ dev-java/jgroups"
+RDEPEND=">=virtual/jre-1.3
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.3
+ ${COMMON_DEP}
+ app-arch/unzip"
+IUSE=""
+
+S=${WORKDIR}
+
+java_prepare() {
+ find . -name "*.jar" -print -delete || die
+}
+
+src_compile() {
+ local build_dir="${S}"/build
+ local classpath="-classpath $(java-pkg_getjars commons-logging,commons-collections,servlet-api-2.3,jms,jgroups):${build_dir}:."
+ mkdir ${build_dir}
+
+ echo "Building core..."
+ cd "${S}"/src/core/java
+ ejavac ${classpath} -nowarn -d ${build_dir} $(find . -name "*.java") || die
+
+ echo "Building cluster support plugin..."
+ cd "${S}"/src/plugins/clustersupport/java
+ find . -name "*.java" -exec sed -i -e "s/org.javagroups/org.jgroups/g" {} \;
+ ejavac ${classpath} -nowarn -d ${build_dir} $(find . -name "*.java") || die
+
+ echo "Building disk persistence plugin..."
+ cd "${S}"/src/plugins/diskpersistence/java
+ ejavac ${classpath} -nowarn -d ${build_dir} `find . -name "*.java"` || die "compile failed"
+
+ if use doc ; then
+ echo "Building documentation..."
+ mkdir "${S}"/javadoc
+ cd ${build_dir}
+ local sourcepath="${S}/src/core/java:${S}/src/plugins/diskpersistence/java:${S}/src/plugins/clustersupport/java"
+ javadoc ${classpath} -sourcepath ${sourcepath} -d "${S}"/javadoc \
+ $(find com/opensymphony/oscache -type d | tr '/' '.') \
+ || die "failed to create javadoc"
+ fi
+
+ cd "${S}"
+ jar cf ${PN}.jar -C build . || die "jar failed"
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ dodoc readme.txt
+ use doc && java-pkg_dojavadoc javadoc
+}