summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/osgi-compendium
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/osgi-compendium')
-rw-r--r--dev-java/osgi-compendium/Manifest1
-rw-r--r--dev-java/osgi-compendium/metadata.xml5
-rw-r--r--dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild47
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/osgi-compendium/Manifest b/dev-java/osgi-compendium/Manifest
new file mode 100644
index 000000000000..3f7817aeb7d4
--- /dev/null
+++ b/dev-java/osgi-compendium/Manifest
@@ -0,0 +1 @@
+DIST osgi.cmpn-4.3.1.jar 741615 SHA256 d73af7676eb25236057598907ae40c7542b6a8dcdd5b9a0001552fb4b2134bbe SHA512 803e929b4b7cfee13a3ffa2c60ad03775afd8409c972bf26e3f79abc590466c2d885bdc339d9af2a3e8fda9cdf082d23a298362ac37935b0ede0719dee27e9f9 WHIRLPOOL d24c488ed334bd634b1b5349e433274af5534a442c7a934b1f891279f4e9269459d84aed2bcdc96f268ae4ea8d25b49dcaf70e12d6c344899dbe0279c6148ab9
diff --git a/dev-java/osgi-compendium/metadata.xml b/dev-java/osgi-compendium/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/osgi-compendium/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild b/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
new file mode 100644
index 000000000000..96cb62778379
--- /dev/null
+++ b/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Compendium API (Companion Code)"
+HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
+SRC_URI="http://www.osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RESTRICT="bindist fetch"
+
+COMMON_DEPEND="dev-java/glassfish-persistence:0
+ dev-java/osgi-core-api:0
+ dev-java/osgi-foundation:0
+ dev-java/tomcat-servlet-api:3.0"
+
+DEPEND="${COMMON_DEPEND}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+RDEPEND="${COMMON_DEPEND}
+ >=virtual/jre-1.5"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+JAVA_GENTOO_CLASSPATH="glassfish-persistence,osgi-core-api,osgi-foundation,tomcat-servlet-api-3.0"
+
+pkg_nofetch() {
+ einfo "Please download osgi.cmpn-${PV}.jar from"
+ einfo " http://www.osgi.org/Download/Release4V43"
+ einfo "which you can find listed as"
+ einfo " OSGi Service Platform Release 4 Version 4.3 Compendium Companion Code"
+ einfo "after accepting the license."
+}
+
+java_prepare() {
+ rm -r org || die
+}