summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-11-10 10:10:35 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-11-10 10:10:35 +0100
commit8d6e12303c72d9a7d07f63675a0d11c9f89f432b (patch)
tree7e3d7203b94dac1939ae506938284b21b8573692 /dev-java/picocli
parentmedia-sound/sonic-visualiser: removed obsolete 4.3-r1 (diff)
downloadgentoo-8d6e12303c72d9a7d07f63675a0d11c9f89f432b.tar.gz
gentoo-8d6e12303c72d9a7d07f63675a0d11c9f89f432b.tar.bz2
gentoo-8d6e12303c72d9a7d07f63675a0d11c9f89f432b.zip
dev-java/picocli: bump to 4.6.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/picocli')
-rw-r--r--dev-java/picocli/Manifest1
-rw-r--r--dev-java/picocli/picocli-4.6.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/picocli/Manifest b/dev-java/picocli/Manifest
index 0a79ef29ced1..3039a82b2230 100644
--- a/dev-java/picocli/Manifest
+++ b/dev-java/picocli/Manifest
@@ -1 +1,2 @@
DIST picocli-4.6.1-sources.tar.gz 13467061 BLAKE2B fd7dc19d572e975a4b47ac0bd9a7ab4be0f5fdf1e3e03c2d3b5026ee9ad6cbcf5e6214234746551d61c427915095e067f44c1d3dfb27071456e76db26d567b23 SHA512 e2c6c6171c3ec9cbe35e7034e119dfe922993c9e7b8d81ea94faeb8b24c9c4c26023be1edb5d67041119c4bf73077d522fbe711e8c1af788063663e2bb06ab1f
+DIST picocli-4.6.2-sources.tar.gz 13488726 BLAKE2B dbec032bd0f40a45172e7c72884c32c9f769a9df0bdacc1904f3d45f4b02d1a3cc7c541a2ae4ca8a6754d67b5351412e4d91f2dc6fbbb3fc37bc4e2776ccdd68 SHA512 83ae37666a3c703b186cdb920095ad46de46de9a092841c352ec7db33877fa102afbd24227a1f73cad8be8a75b800f5c1487a8720d7080bdc8aa20dd8acafbe4
diff --git a/dev-java/picocli/picocli-4.6.2.ebuild b/dev-java/picocli/picocli-4.6.2.ebuild
new file mode 100644
index 000000000000..fc331f6ba11f
--- /dev/null
+++ b/dev-java/picocli/picocli-4.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/remkop/picocli/archive/refs/tags/v4.6.2.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild picocli-4.6.2.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="info.picocli:picocli:4.6.2"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java command line parser with both an annotations API and a programmatic API"
+HOMEPAGE="http://picocli.info"
+SRC_URI="https://github.com/remkop/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+# package org.junit.contrib.java.lang.system does not exist
+# the project is here: https://github.com/stefanbirkner/system-rules
+RESTRICT="test"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+DOCS=( LICENSE README.md RELEASE-NOTES.md )
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/resources"
+)