summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/picocontainer/picocontainer-1.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/picocontainer/picocontainer-1.1-r1.ebuild')
-rw-r--r--dev-java/picocontainer/picocontainer-1.1-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/picocontainer/picocontainer-1.1-r1.ebuild b/dev-java/picocontainer/picocontainer-1.1-r1.ebuild
new file mode 100644
index 000000000000..abb2c9c1c70d
--- /dev/null
+++ b/dev-java/picocontainer/picocontainer-1.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Small footprint Dependency Injection container"
+HOMEPAGE="http://www.picocontainer.org"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.5
+ source? ( app-arch/zip )
+ "
+# test? (
+# >=dev-java/junit-3.8.1
+# )"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Don't run tests automatically
+ sed -i -e 's/compile,test/compile/' build.xml || die
+
+# doesn't pass internal test even when trying vanilla build.xml that fetches own libs
+# if use test ; then
+# mkdir -p target/lib
+# cd target/lib
+# java-pkg_jar-from junit junit-3.8.1.jar
+# fi
+}
+
+src_compile() {
+ local antflags="-Dfinal.name=${PN} -Dnoget=true jar"
+ eant ${antflags} $(use_doc)
+}
+
+#src_test() {
+# local antflags="-Dfinal.name=${PN} -Dnoget=true test"
+# eant ${antflags}
+#}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/org
+}