summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam L. Thomson Jr <wlt@o-sinc.com>2015-09-17 20:01:30 -0400
committerJames Le Cuirot <chewi@gentoo.org>2015-09-29 22:19:39 +0100
commit3b77b318c2ae3e1856ed2d9525754ab56e12526b (patch)
treea0642d4a692e766442e261709f59e21147d078c9 /dev-java/rome
parentdev-java/junit-addons: Updated dev-java/jdom slot from 1.0 -> 0 for v1 (diff)
downloadgentoo-3b77b318c2ae3e1856ed2d9525754ab56e12526b.tar.gz
gentoo-3b77b318c2ae3e1856ed2d9525754ab56e12526b.tar.bz2
gentoo-3b77b318c2ae3e1856ed2d9525754ab56e12526b.zip
dev-java/rome: Updated dev-java/jdom slot from 1.0 -> 0 for v1
Diffstat (limited to 'dev-java/rome')
-rw-r--r--dev-java/rome/rome-0.9-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/rome/rome-0.9-r1.ebuild b/dev-java/rome/rome-0.9-r1.ebuild
new file mode 100644
index 000000000000..cb20ae05d18d
--- /dev/null
+++ b/dev-java/rome/rome-0.9-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Open source Atom/RSS Java utilities that make it easy to work in Java with most syndication formats"
+HOMEPAGE="https://java.net/projects/rome"
+SRC_URI="https://rome.dev.java.net/source/browse/*checkout*/rome/www/dist/${P}-src.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND="dev-java/jdom:0"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch build.xml so the tests pass
+ epatch "${FILESDIR}/${P}-build.xml-test-upstream.patch"
+
+ # Symlink jars
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from jdom-1.0
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
+
+src_test() {
+ java-pkg_jar-from --into target/lib junit
+ ANT_TASKS="ant-junit" eant test
+}