summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/snappy/files/1.1.0.1-unbundle-snappy.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/snappy/files/1.1.0.1-unbundle-snappy.patch')
-rw-r--r--dev-java/snappy/files/1.1.0.1-unbundle-snappy.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/snappy/files/1.1.0.1-unbundle-snappy.patch b/dev-java/snappy/files/1.1.0.1-unbundle-snappy.patch
new file mode 100644
index 000000000000..17fb2e1583ed
--- /dev/null
+++ b/dev-java/snappy/files/1.1.0.1-unbundle-snappy.patch
@@ -0,0 +1,51 @@
+diff --git a/Makefile b/Makefile
+index 0821c87..04f0435 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,7 +7,8 @@ all: snappy
+
+ SNAPPY_OUT:=$(TARGET)/$(snappy)-$(os_arch)
+ SNAPPY_ARCHIVE:=$(TARGET)/snappy-$(VERSION).tar.gz
+-SNAPPY_CC:=snappy-sinksource.cc snappy-stubs-internal.cc snappy.cc
++#SNAPPY_CC:=snappy-sinksource.cc snappy-stubs-internal.cc snappy.cc
++SNAPPY_CC:=
+ SNAPPY_SRC_DIR:=$(TARGET)/snappy-$(VERSION)
+ SNAPPY_SRC:=$(addprefix $(SNAPPY_SRC_DIR)/,$(SNAPPY_CC))
+ SNAPPY_OBJ:=$(addprefix $(SNAPPY_OUT)/,$(patsubst %.cc,%.o,$(SNAPPY_CC)) SnappyNative.o)
+@@ -46,7 +47,8 @@ src/main/resources/org/xerial/snappy/SnappyNativeLoader.bytecode: src/main/resou
+ $(JAVAC) -source 1.5 -target 1.5 -d $(TARGET)/temp $<
+ cp $(TARGET)/temp/org/xerial/snappy/SnappyNativeLoader.class $@
+
+-$(SNAPPY_SRC): $(SNAPPY_UNPACKED)
++$(SNAPPY_SRC):
++# $(SNAPPY_UNPACKED)
+
+ $(SNAPPY_OUT)/%.o : $(SNAPPY_SRC_DIR)/%.cc
+ @mkdir -p $(@D)
+@@ -58,7 +60,7 @@ $(SNAPPY_OUT)/SnappyNative.o : $(SRC)/org/xerial/snappy/SnappyNative.cpp $(SRC)/
+
+
+ $(SNAPPY_OUT)/$(LIBNAME): $(SNAPPY_OBJ)
+- $(CXX) $(CXXFLAGS) -o $@ $+ $(LINKFLAGS)
++ $(CXX) $(CXXFLAGS) -o $@ $+ $(LINKFLAGS) -lsnappy
+ $(STRIP) $@
+
+ clean-native:
+@@ -73,14 +75,15 @@ NATIVE_DLL:=$(NATIVE_DIR)/$(LIBNAME)
+
+ snappy-jar-version:=snappy-java-$(shell $(JAVA) -jar lib/silk-weaver.jar find 'project(artifactId, version)' pom.xml | grep snappy-java | awk '{ print $$2; }')
+
+-native: $(SNAPPY_UNPACKED) $(NATIVE_DLL)
+-snappy: native $(TARGET)/$(snappy-jar-version).jar
++native: $(NATIVE_DLL)
++snappy: native
+
+ $(NATIVE_DLL): $(SNAPPY_OUT)/$(LIBNAME)
+ @mkdir -p $(@D)
+ cp $< $@
+ @mkdir -p $(NATIVE_TARGET_DIR)
+ cp $< $(NATIVE_TARGET_DIR)/$(LIBNAME)
++ cp $< $(TARGET)/
+
+
+ $(TARGET)/$(snappy-jar-version).jar: native $(NATIVE_DLL)