summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/stax2-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/stax2-api')
-rw-r--r--dev-java/stax2-api/Manifest1
-rw-r--r--dev-java/stax2-api/metadata.xml9
-rw-r--r--dev-java/stax2-api/stax2-api-4.0.0.ebuild33
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/stax2-api/Manifest b/dev-java/stax2-api/Manifest
new file mode 100644
index 000000000000..f26b79fe4ffd
--- /dev/null
+++ b/dev-java/stax2-api/Manifest
@@ -0,0 +1 @@
+DIST stax2-api-4.0.0.tar.gz 127125 SHA256 7872551a4d8ba75aaa25bea4709df943d90989ffb672a505f71e020aa20eacaa SHA512 a8636de873c97534fe17738efb9892d38c52a1a6adfec9502b727082f24b57dc5bfd10a67b5f5d9e196a53d7ee461978dcf8e6c306168bd1cf96a6d67c655b5b WHIRLPOOL a99dcdd266186d9ac7eda61da43cfe74a45a6396ad790029bf84593fe9dc3644c221a0e3b507a57486e8f2de0c1e9644e02946b5391f25c89887d427c0d38e5c
diff --git a/dev-java/stax2-api/metadata.xml b/dev-java/stax2-api/metadata.xml
new file mode 100644
index 000000000000..7a57fb0cf6c5
--- /dev/null
+++ b/dev-java/stax2-api/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>Stax2 API is an extension to standard Stax API ("STandard Api for Xml procesing"), pull-parser API of JDK, added in JDK 6.</longdescription>
+ <upstream>
+ <remote-id type="github">FasterXML/stax2-api</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/stax2-api/stax2-api-4.0.0.ebuild b/dev-java/stax2-api/stax2-api-4.0.0.ebuild
new file mode 100644
index 000000000000..30f2514e0bba
--- /dev/null
+++ b/dev-java/stax2-api/stax2-api-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Extended Stax (STandard Api for Xml procesing) API"
+HOMEPAGE="https://github.com/FasterXML/stax2-api"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="java-virtuals/stax-api:0
+ >=virtual/jre-1.5"
+
+DEPEND="java-virtuals/stax-api:0
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${P}/src"
+JAVA_SRC_DIR="main/java"
+JAVA_GENTOO_CLASSPATH="stax-api"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md ../release-notes/VERSION
+}