summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/struts-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/struts-core')
-rw-r--r--dev-java/struts-core/Manifest2
-rw-r--r--dev-java/struts-core/files/struts-2.3.15.2-build.xml-classpath.patch20
-rw-r--r--dev-java/struts-core/files/struts-2.3.15.2-build.xml-manifest.patch15
-rw-r--r--dev-java/struts-core/metadata.xml5
-rw-r--r--dev-java/struts-core/struts-core-2.3.15.2.ebuild67
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-java/struts-core/Manifest b/dev-java/struts-core/Manifest
new file mode 100644
index 000000000000..c2974670e4ab
--- /dev/null
+++ b/dev-java/struts-core/Manifest
@@ -0,0 +1,2 @@
+DIST struts-2.3.15.2-src.zip 6957356 SHA256 26d85c52e7764ece49ccd7b9df38353003326116363a630ee8ae33bc26db3cd5 SHA512 55df8ea52717781efe1b34b0b09b8677c88ce50cf160119bebfec979f22d95b0a801b9e1184dba3733ca80e9db27297d42412ae550eaa4451e4aad6f25b66825 WHIRLPOOL dcc7d263c22ada417e3e3c518d10e2a8937cda0755110bcf29981c1eec7ce8e3b9b6260c708e0292916d9e5fb11b9d35a061b2e823254d0c2030a95035a67a86
+DIST struts-build.xml-2.3.15.2.tar.xz 20744 SHA256 c76b3d852140f3ff62718949ec752673b99845abe028445fbca69fd9f4879d5b SHA512 d4c21ff8dea2990507bff4968311a4f6a44c17ae1cbbd321b818d3fe558c131ee6c0132d5e61509f61aa53e284b61fb3cce24b89020f9889cf9ef960b7c31da3 WHIRLPOOL 7f42a22a5a43f91aba871ce4f04a38b0f1314b47395d22054bc6922b7565bb6c978141bb5a1b1274f7bfc9bd51a863ddcde9f711c1374f1cb5c707b0613e1897
diff --git a/dev-java/struts-core/files/struts-2.3.15.2-build.xml-classpath.patch b/dev-java/struts-core/files/struts-2.3.15.2-build.xml-classpath.patch
new file mode 100644
index 000000000000..1ce5974427b7
--- /dev/null
+++ b/dev-java/struts-core/files/struts-2.3.15.2-build.xml-classpath.patch
@@ -0,0 +1,20 @@
+--- a/maven-build.xml
++++ b/maven-build.xml
+@@ -125,7 +125,7 @@
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+- <javac destdir="${maven.build.outputDir}"
++ <javac destdir="${maven.build.outputDir}" classpath="${gentoo.classpath}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+@@ -153,7 +153,7 @@
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+- <javac destdir="${maven.build.testOutputDir}"
++ <javac destdir="${maven.build.testOutputDir}" classpath="${gentoo.test.classpath}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
diff --git a/dev-java/struts-core/files/struts-2.3.15.2-build.xml-manifest.patch b/dev-java/struts-core/files/struts-2.3.15.2-build.xml-manifest.patch
new file mode 100644
index 000000000000..001b5fdb4630
--- /dev/null
+++ b/dev-java/struts-core/files/struts-2.3.15.2-build.xml-manifest.patch
@@ -0,0 +1,15 @@
+--- a/core/maven-build.xml
++++ b/core/maven-build.xml
+@@ -271,12 +271,8 @@
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+- manifest="/var/tmp/portage/dev-java/struts-xwork-2.3.15.2/work/struts-2.3.15.2/src/core/target/classes/META-INF/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+- <manifest>
+- <attribute name="Main-Class"/>
+- </manifest>
+ </jar>
+ </target>
+
diff --git a/dev-java/struts-core/metadata.xml b/dev-java/struts-core/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/struts-core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/struts-core/struts-core-2.3.15.2.ebuild b/dev-java/struts-core/struts-core-2.3.15.2.ebuild
new file mode 100644
index 000000000000..9b3f261db9a8
--- /dev/null
+++ b/dev-java/struts-core/struts-core-2.3.15.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="struts"
+MY_P="${MY_PN}-${PV}-src"
+
+DESCRIPTION="A powerful Model View Controller Framework for JSP/Servlets: Core"
+SRC_URI="mirror://apache/struts/source/${MY_P}.zip
+ http://dev.gentoo.org/~tomwij/files/dist/${MY_PN}-build.xml-${PV}.tar.xz"
+HOMEPAGE="http://struts.apache.org/index.html"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+
+COMMON_DEPS="dev-java/commons-fileupload:0
+ dev-java/commons-lang:3.1
+ dev-java/freemarker:2.3
+ dev-java/ognl:3.0
+ dev-java/struts-xwork:2
+ dev-java/velocity:0
+ java-virtuals/servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPS}"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src/core"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="struts-xwork-2"
+
+src_unpack() {
+ unpack ${MY_P}.zip
+ cd "${WORKDIR}"/${MY_PN}-${PV}/src || die
+ unpack ${MY_PN}-build.xml-${PV}.tar.xz
+
+ java-pkg_getjars commons-fileupload,commons-lang-3.1,freemarker-2.3,ognl-3.0,velocity,servlet-api-3.0
+}
+
+java_prepare() {
+ find . -name '*.jar' -print -delete || die
+
+ epatch "${FILESDIR}"/${MY_PN}-${PV}-build.xml-classpath.patch
+ epatch "${FILESDIR}"/${MY_PN}-${PV}-build.xml-manifest.patch
+}
+
+src_test() {
+ EANT_TEST_EXTRA_ARGS="-Djunit.present=true" java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_PN}2-core-${PV}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/com
+}