summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/tagsoup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/tagsoup')
-rw-r--r--dev-java/tagsoup/Manifest1
-rw-r--r--dev-java/tagsoup/metadata.xml11
-rw-r--r--dev-java/tagsoup/tagsoup-1.2.1.ebuild43
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/tagsoup/Manifest b/dev-java/tagsoup/Manifest
new file mode 100644
index 000000000000..6be2ad11c58d
--- /dev/null
+++ b/dev-java/tagsoup/Manifest
@@ -0,0 +1 @@
+DIST tagsoup-1.2.1-src.zip 222757 SHA256 fe4bb031f2c62461337afe81f8f70df463dc5edb39bd4145c002f6d10a891ece SHA512 3bb1608746270663f6ed45318457e3ee27419929411689d962cffc0ab0c32ec4b858020043be46e929014b696c753a01b49d6eea9a98f18d81fb9205e99ac0a1 WHIRLPOOL 45fd3f63d7582dbc9358874f7f15504fb2e364d7d10fb372b7c2f92791e330f0b2e297795c66b789762ee27c5d125c455dd6a0558be2bd459329fb53eba1bb4c
diff --git a/dev-java/tagsoup/metadata.xml b/dev-java/tagsoup/metadata.xml
new file mode 100644
index 000000000000..4618b26cc2d8
--- /dev/null
+++ b/dev-java/tagsoup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ This is the home page of TagSoup, a SAX-compliant parser written
+ in Java that, instead of parsing well-formed or valid XML, parses
+ HTML as it is found in the wild: nasty and brutish, though quite
+ often far from short.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/tagsoup/tagsoup-1.2.1.ebuild b/dev-java/tagsoup/tagsoup-1.2.1.ebuild
new file mode 100644
index 000000000000..c6fbb1b6bade
--- /dev/null
+++ b/dev-java/tagsoup/tagsoup-1.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A SAX-compliant parser written in Java"
+HOMEPAGE="http://mercury.ccil.org/~cowan/XML/tagsoup/"
+SRC_URI="http://mercury.ccil.org/~cowan/XML/tagsoup/${P}-src.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.4"
+DEPEND="
+ >=virtual/jdk-1.4
+ dev-java/saxon:9
+ app-arch/unzip"
+
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="docs-api"
+# Fails to detect a TransformerFactory. #421733
+# See also https://issues.apache.org/jira/browse/XALANJ-1549 for why the default is no good either.
+EANT_ANT_TASKS="saxon-9"
+EANT_EXTRA_ARGS="-Dtransformer.factory=net.sf.saxon.TransformerFactoryImpl"
+
+src_install() {
+ java-pkg_newjar dist/lib/${PN}-1.2.jar ${PN}.jar
+ java-pkg_dolauncher
+
+ doman ${PN}.1 || die
+ dodoc CHANGES README TODO || die
+
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/{java,templates}/*
+}