summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/tomcat-jstl-impl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/tomcat-jstl-impl')
-rw-r--r--dev-java/tomcat-jstl-impl/Manifest1
-rw-r--r--dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch35
-rw-r--r--dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch33
-rw-r--r--dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml244
-rw-r--r--dev-java/tomcat-jstl-impl/metadata.xml5
-rw-r--r--dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5.ebuild73
6 files changed, 391 insertions, 0 deletions
diff --git a/dev-java/tomcat-jstl-impl/Manifest b/dev-java/tomcat-jstl-impl/Manifest
new file mode 100644
index 000000000000..3d40f6296597
--- /dev/null
+++ b/dev-java/tomcat-jstl-impl/Manifest
@@ -0,0 +1 @@
+DIST taglibs-standard-1.2.5-source-release.zip 615779 SHA256 09206f14ae3bbfc5442476414feee422d4371a6dbe0e3435eb84462b6f36cd84 SHA512 ad4122cd75c66df901034e333c2b38ac3d2d8f5b0299abd36d0fd1c8f5975eacc71d66a475fc05638dd562ab0670ea532fe6a3ccb5497dfbeb9d859b03b659d0 WHIRLPOOL 2cc5c667fbce1bda85b935b0081c99ce454dad666e5a1609ba0ff7c9363265427df48dbe86e549e608f9d977d726f7d6f3b1dea803ebc6b1c78eb139eb2464ff
diff --git a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch
new file mode 100644
index 000000000000..f43dfc1f903b
--- /dev/null
+++ b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch
@@ -0,0 +1,35 @@
+--- impl/src/main/java/org/apache/taglibs/standard/tag/common/core/ImportSupport.java.orig 2015-06-01 22:34:34.882000000 +0000
++++ impl/src/main/java/org/apache/taglibs/standard/tag/common/core/ImportSupport.java 2015-06-01 22:35:29.078000000 +0000
+@@ -36,6 +36,7 @@
+ import javax.servlet.ServletContext;
+ import javax.servlet.ServletException;
+ import javax.servlet.ServletOutputStream;
++import javax.servlet.WriteListener;
+ import javax.servlet.http.HttpServletRequest;
+ import javax.servlet.http.HttpServletResponse;
+ import javax.servlet.http.HttpServletResponseWrapper;
+@@ -430,6 +431,24 @@
+ public void write(int b) throws IOException {
+ bos.write(b);
+ }
++
++ @Override
++ public boolean isReady() {
++ return true;
++ }
++
++ @Override
++ public void setWriteListener(WriteListener writeListener) {
++ }
++
++ @Override
++ public void close() throws IOException {
++ }
++
++ @Override
++ public void flush() throws IOException {
++ }
++
+ };
+
+ /**
diff --git a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch
new file mode 100644
index 000000000000..9ed4ed84a38d
--- /dev/null
+++ b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch
@@ -0,0 +1,33 @@
+--- impl/src/test/java/org/apache/taglibs/standard/tag/common/core/SetSupportTest.java.orig 2015-06-01 22:59:35.208000000 +0000
++++ impl/src/test/java/org/apache/taglibs/standard/tag/common/core/SetSupportTest.java 2015-06-01 22:59:54.191000000 +0000
+@@ -334,30 +334,12 @@
+ }
+
+ @Test
+- public void testResultFromBodyContent() throws JspException {
+- tag = new MockSetSupport();
+- BodyContent bodyContent = createMock(BodyContent.class);
+- expect(bodyContent.getString()).andStubReturn(" Hello ");
+- replay(bodyContent);
+- tag.setBodyContent(bodyContent);
+- Assert.assertEquals(VALUE, tag.getResult());
+- }
+-
+- @Test
+ public void testResultFromNullBodyContent() throws JspException {
+ tag = new MockSetSupport();
+ tag.setBodyContent(null);
+ Assert.assertEquals(tag.getResult(), "");
+ }
+
+- @Test
+- public void testResultFromEmptyBodyContent() throws JspException {
+- tag = new MockSetSupport();
+- BodyContent bodyContent = createMock(BodyContent.class);
+- expect(bodyContent.getString()).andStubReturn(null);
+- Assert.assertEquals("", tag.getResult());
+- }
+-
+ public static class MockSetSupport extends SetSupport {
+ private final boolean valueSpecified;
+ private final Object value;
diff --git a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml
new file mode 100644
index 000000000000..fce6b8d72338
--- /dev/null
+++ b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml
@@ -0,0 +1,244 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/1/15 9:48 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="taglibs-standard-impl-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="taglibs-standard-impl-1.2.5"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ <exclude name="**/ExprSupportTest.java"/>
+ <exclude name="**/EscapeXMLTest.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ <exclude name="**/ExprSupportTest.java"/>
+ <exclude name="**/EscapeXMLTest.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/tomcat-jstl-impl/metadata.xml b/dev-java/tomcat-jstl-impl/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/tomcat-jstl-impl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5.ebuild b/dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5.ebuild
new file mode 100644
index 000000000000..6ac34002d82c
--- /dev/null
+++ b/dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_PN="taglibs-standard"
+MY_P="${MY_PN}-${PV}"
+MY_IMPL="${MY_PN}-impl"
+
+DESCRIPTION="JSP Standard Tag Library (JSTL) - Implementation jar"
+HOMEPAGE="https://tomcat.apache.org/taglibs/standard/"
+SRC_URI="http://apache.mirrors.ovh.net/ftp.apache.org/dist/tomcat/taglibs/${MY_P}/${MY_P}-source-release.zip"
+
+LICENSE="Apache-2.0"
+SLOT="1.2.5"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-java/xalan:0
+ dev-java/tomcat-jstl-spec:1.2.5
+ dev-java/tomcat-servlet-api:3.1"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/easymock:3.2
+ )
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="tomcat-servlet-api-3.1,tomcat-jstl-spec-1.2.5,xalan"
+EANT_BUILD_TARGET="package"
+EANT_BUILD_XML="impl/build.xml"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml "${S}"/impl/build.xml
+
+ # This patch overrides a couple of methods.
+ epatch "${FILESDIR}"/${P}-ImportSupport.patch
+
+ # This one disables one test case which doesn't work.
+ epatch "${FILESDIR}"/${P}-SetSupport.patch
+
+ # This test case doesn't pass.
+ rm -v \
+ impl/src/test/java/org/apache/taglibs/standard/tag/common/fmt/BundleSupportTest.java
+}
+
+EANT_TEST_TARGET="test"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},easymock-3.2"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "${S}"/impl/target/${MY_IMPL}-${PV}.jar ${MY_IMPL}.jar
+
+ if use doc; then
+ java-pkg_dohtml -r "${S}"/impl/target/site/apidocs/
+ fi
+
+ if use source; then
+ java-pkg_dosrc "${S}"/impl/src/*
+ fi
+}