summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/tomcat-native
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/Manifest2
-rw-r--r--dev-java/tomcat-native/metadata.xml15
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.32.ebuild47
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.33.ebuild47
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-java/tomcat-native/Manifest b/dev-java/tomcat-native/Manifest
new file mode 100644
index 000000000000..a4b3064b585e
--- /dev/null
+++ b/dev-java/tomcat-native/Manifest
@@ -0,0 +1,2 @@
+DIST tomcat-native-1.1.32-src.tar.gz 387267 SHA256 26936848f727e162f513bd2b5f7b2300d7d716a5e92e5f4ebcd0e1eff8e09584 SHA512 695f710f91cf720b3115f9933f5dab56e7465ee0fcf6508b53d1de172ba59165b08f27b3cdfef741b60dbf0b3da97ae3ea87c5a0ef9f1d879a9820259197dcba WHIRLPOOL 587c25124ab5b07365a0c26ee558086b690d6b0cb568f6670ecd7b8a79a25fa74091bc7a10574732b96600eca0ae4141119adc40c51b45c7ef87de631a38aeb8
+DIST tomcat-native-1.1.33-src.tar.gz 388787 SHA256 523dde7393c57307eedf4972ebbe19a9e9af6f7699e3b1ef6dabd7a11677866e SHA512 62b3c806cd926ca13878b514714a422f4a5d932ccaee4cc328c101cfa92fd890f708d1fb429320a42f1e340b46f70c82a07b9ecf6cbd9d03c0e719b95e24e09b WHIRLPOOL afb57fdf32becae8860ed042d74e27a7208759c4a7c16163148e65c986b4dcfa9521e83bbe0a3fa6874a87f577be2ad31a043d3ec1888c11faec7ace21035419
diff --git a/dev-java/tomcat-native/metadata.xml b/dev-java/tomcat-native/metadata.xml
new file mode 100644
index 000000000000..356b51e0d53b
--- /dev/null
+++ b/dev-java/tomcat-native/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ Native library for Tomcat to use the Apache Portable Runtime to
+ provide superior scalability, performance, and better integration with
+ native server technologies. The Apache Portable Runtime is a highly
+ portable library that is at the heart of Apache HTTP Server 2.x. APR
+ has many uses, including access to advanced IO functionality (such as
+ sendfile, epoll and OpenSSL), OS level functionality (random number
+ generation, system status, etc), and native process handling (shared
+ memory, NT pipes and Unix sockets).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.32.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.32.ebuild
new file mode 100644
index 000000000000..bd2d60e664c1
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.32.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="amd64 x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild
new file mode 100644
index 000000000000..5950648af7b1
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl:=
+ >=virtual/jre-1.5:*"
+
+DEPEND=">=virtual/jdk-1.5:*
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}