summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-04 14:07:01 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-04 14:07:26 +0000
commitcf9a30d5f3583d7ed7e73d056d89926591ea7d1d (patch)
tree191fe0e0ca6122881fcbc30cd60f1504208a5691 /dev-java/typesafe-config/typesafe-config-1.2.1.ebuild
parentapp-emacs/ebuild-mode: add alpha keyword (diff)
downloadgentoo-cf9a30d5f3583d7ed7e73d056d89926591ea7d1d.tar.gz
gentoo-cf9a30d5f3583d7ed7e73d056d89926591ea7d1d.tar.bz2
gentoo-cf9a30d5f3583d7ed7e73d056d89926591ea7d1d.zip
dev-java/typesafe-config: Resolve bug #559748 once and for all
typesafe-config-1.3.0 has a stable revdep (mchange-commons) but requires Java 8, which hasn't been stabilised yet. An ebuild depending on Java 6 was erroneously added to deal with this. We're not quite ready to stabilise Java 8 but we can't drop keywords either so I've added typesafe-config-1.2.1, which only requires Java 6. java-apicheck highlighted some differences but I've kept the same SLOT because mchange-commons works with either. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-java/typesafe-config/typesafe-config-1.2.1.ebuild')
-rw-r--r--dev-java/typesafe-config/typesafe-config-1.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/typesafe-config/typesafe-config-1.2.1.ebuild b/dev-java/typesafe-config/typesafe-config-1.2.1.ebuild
new file mode 100644
index 000000000000..dadedeef3ad5
--- /dev/null
+++ b/dev-java/typesafe-config/typesafe-config-1.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A library of arguably useful Java utilities"
+HOMEPAGE="https://github.com/typesafehub/config"
+SRC_URI="https://github.com/typesafehub/config/archive/v${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/zip"