summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ws-commons-util
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ws-commons-util')
-rw-r--r--dev-java/ws-commons-util/Manifest1
-rw-r--r--dev-java/ws-commons-util/metadata.xml6
-rw-r--r--dev-java/ws-commons-util/ws-commons-util-1.0.1.ebuild42
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/ws-commons-util/Manifest b/dev-java/ws-commons-util/Manifest
new file mode 100644
index 000000000000..09e839c0666d
--- /dev/null
+++ b/dev-java/ws-commons-util/Manifest
@@ -0,0 +1 @@
+DIST ws-commons-util-1.0.1-src.tar.gz 24838 SHA256 cede9cc3136e09fedfe8ccdf61e3e963afb3c54ccc833262316ceb103b74df88 SHA512 4eefe61daf462105ca8cfb8ec42ef42ef414d1426b201da044fe9a72e9ab7d3fd34bd80d19d8f6220f1f91d9de7cab3d8d2dec4c267784ba3d3bbd69a1c62c4c WHIRLPOOL 545b790e44023d8f0a0fb81de587ea6846eb7ae7af9dbc31f6921d06268d1474ea055134b8485113e991fbe5bcd09ecffff7f48efe99434b5c41e50e0c715e31
diff --git a/dev-java/ws-commons-util/metadata.xml b/dev-java/ws-commons-util/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/ws-commons-util/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/ws-commons-util/ws-commons-util-1.0.1.ebuild b/dev-java/ws-commons-util/ws-commons-util-1.0.1.ebuild
new file mode 100644
index 000000000000..302d75dcee90
--- /dev/null
+++ b/dev-java/ws-commons-util/ws-commons-util-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="1"
+JAVA_PKG_IUSE="source test"
+inherit java-pkg-2
+
+DESCRIPTION="Utility classes that allow high performance XML processing based on SAX"
+HOMEPAGE="http://ws.apache.org/commons/util/"
+SRC_URI="mirror://apache/ws/commons/util/sources/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/junit:0 )"
+
+RDEPEND=">=virtual/jre-1.4"
+
+src_compile() {
+ mkdir -p bin || die
+ ejavac -d bin `find src/main -name "*.java" || die`
+ `java-config -j` cvf "${PN}.jar" -C bin . || die
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ local class files=`find src/test -name "*.java" || die`
+ ejavac -cp bin:`java-pkg_getjars junit` -d bin ${files}
+
+ for class in ${files} ; do
+ class=${class#src/test/java/}
+ class=${class%.java}
+ ejunit -cp bin ${class//\//.}
+ done
+}