summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-18 19:41:49 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-18 19:42:32 +0100
commit481276598f77749335d888099815ada57077d5cc (patch)
tree152f6d29cad1b9e0395d811671a4679f2fed071a /dev-java/xjavac/xjavac-2.4.0.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.55,4.9.16} - remov... (diff)
downloadgentoo-481276598f77749335d888099815ada57077d5cc.tar.gz
gentoo-481276598f77749335d888099815ada57077d5cc.tar.bz2
gentoo-481276598f77749335d888099815ada57077d5cc.zip
dev-java/xjavac: EAPI 6 bump.
This ebuild now uses the java-pkg-simple eclass to compile a simple Java file. Gentoo-Bug: https://bugs.gentoo.org/612808 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-java/xjavac/xjavac-2.4.0.ebuild')
-rw-r--r--dev-java/xjavac/xjavac-2.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/xjavac/xjavac-2.4.0.ebuild b/dev-java/xjavac/xjavac-2.4.0.ebuild
new file mode 100644
index 000000000000..a2928dde6b81
--- /dev/null
+++ b/dev-java/xjavac/xjavac-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Xerses Java Parser"
+HOMEPAGE="https://xerces.apache.org/xerces-j"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.7"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.7"
+
+JAVA_GENTOO_CLASSPATH="ant-core"