summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xp')
-rw-r--r--dev-java/xp/Manifest1
-rw-r--r--dev-java/xp/files/0.5-fix-jdk-1.7-enum.patch30
-rw-r--r--dev-java/xp/files/build.xml12
-rw-r--r--dev-java/xp/metadata.xml5
-rw-r--r--dev-java/xp/xp-0.5-r2.ebuild41
5 files changed, 89 insertions, 0 deletions
diff --git a/dev-java/xp/Manifest b/dev-java/xp/Manifest
new file mode 100644
index 000000000000..7c79dc5ee865
--- /dev/null
+++ b/dev-java/xp/Manifest
@@ -0,0 +1 @@
+DIST xp.zip 281324 SHA256 38b35ca80627afafdaa2140f7df339164abb5fceffe8b5783dadc75a05662a1d SHA512 5bf354967a1135209d5c6b3be979a311aa5c909493dea16a0efd31a1838dda12be4005ac7e919620ed68266a333fdc93a07853ec1e0af0e83b329bd40bda74b6 WHIRLPOOL 677a8a52ed3d656a1924cf54c82b4c0688c5736771b4add8e878c0e8ecd049efcc85e7f15b883004e4b7d469bbfc207585860e1c2ccfcaa6c4e2fc81cf05d6a5
diff --git a/dev-java/xp/files/0.5-fix-jdk-1.7-enum.patch b/dev-java/xp/files/0.5-fix-jdk-1.7-enum.patch
new file mode 100644
index 000000000000..d2c11ab3ed59
--- /dev/null
+++ b/dev-java/xp/files/0.5-fix-jdk-1.7-enum.patch
@@ -0,0 +1,30 @@
+diff --git a/com/jclark/xml/sax/Driver.java b/com/jclark/xml/sax/Driver.java
+index 2b0d90a..d1efd3e 100644
+--- a/com/jclark/xml/sax/Driver.java
++++ b/com/jclark/xml/sax/Driver.java
+@@ -160,9 +160,9 @@ public class Driver extends ApplicationImpl
+
+ DTD dtd = event.getDTD();
+
+- for (Enumeration enum = dtd.entityNames(DTD.NOTATION);
+- enum.hasMoreElements(); ) {
+- String name = (String)enum.nextElement();
++ for (Enumeration enumx = dtd.entityNames(DTD.NOTATION);
++ enumx.hasMoreElements(); ) {
++ String name = (String)enumx.nextElement();
+ Entity entity = dtd.getEntity(DTD.NOTATION, name);
+ String systemId = entity.getSystemId();
+ if (systemId != null) {
+@@ -173,9 +173,9 @@ public class Driver extends ApplicationImpl
+ }
+ dtdHandler.notationDecl(name, entity.getPublicId(), systemId);
+ }
+- for (Enumeration enum = dtd.entityNames(DTD.GENERAL_ENTITY);
+- enum.hasMoreElements();) {
+- String name = (String)enum.nextElement();
++ for (Enumeration enumx = dtd.entityNames(DTD.GENERAL_ENTITY);
++ enumx.hasMoreElements();) {
++ String name = (String)enumx.nextElement();
+ Entity entity = dtd.getEntity(DTD.GENERAL_ENTITY, name);
+ String notationName = entity.getNotationName();
+ if (notationName != null) {
diff --git a/dev-java/xp/files/build.xml b/dev-java/xp/files/build.xml
new file mode 100644
index 000000000000..cea20e923774
--- /dev/null
+++ b/dev-java/xp/files/build.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+
+<project name="xp" default="jar">
+ <target name="compile">
+ <mkdir dir="build" />
+ <javac srcdir="." destdir="build" />
+ </target>
+
+ <target name="jar" depends="compile">
+ <jar jarfile="xp.jar" basedir="build" />
+ </target>
+</project>
diff --git a/dev-java/xp/metadata.xml b/dev-java/xp/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/xp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/xp/xp-0.5-r2.ebuild b/dev-java/xp/xp-0.5-r2.ebuild
new file mode 100644
index 000000000000..3ba1678245a2
--- /dev/null
+++ b/dev-java/xp/xp-0.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="XP is an XML 1.0 parser written in Java"
+HOMEPAGE="http://www.jclark.com/xml/xp"
+SRC_URI="ftp://ftp.jclark.com/pub/xml/xp.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}"
+
+java_prepare() {
+ rm -v xp.jar || die
+ cp "${FILESDIR}/build.xml" . || die
+ epatch "${FILESDIR}"/${PV}-*.patch
+}
+
+#premade javadocs
+EANT_DOC_TARGET=""
+
+src_install() {
+ java-pkg_dojar xp.jar
+ dodoc docs/copying.txt
+ #has index.html and javadocs here
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc com
+}