summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xpp3/xpp3-1.1.4c-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xpp3/xpp3-1.1.4c-r1.ebuild')
-rw-r--r--dev-java/xpp3/xpp3-1.1.4c-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/xpp3/xpp3-1.1.4c-r1.ebuild b/dev-java/xpp3/xpp3-1.1.4c-r1.ebuild
new file mode 100644
index 000000000000..42506fd42ebb
--- /dev/null
+++ b/dev-java/xpp3/xpp3-1.1.4c-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PV=${PV/m/.M}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="An implementation of XMLPULL V1 API"
+HOMEPAGE="http://www.extreme.indiana.edu/xgws/xsoap/xpp/mxp1/index.html"
+SRC_URI="http://www.extreme.indiana.edu/dist/java-repository/${PN}/distributions/${MY_P}_src.zip"
+
+LICENSE="Apache-1.1 IBM JDOM LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -v *.jar || die
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" \
+ eant -Dgentoo.classpath=$(java-pkg_getjars junit) junit_main
+}
+
+src_install() {
+ java-pkg_newjar build/${MY_P}.jar ${PN}.jar
+
+ dohtml doc/*.html || die
+ dodoc doc/*.txt || die
+
+ use doc && java-pkg_dojavadoc doc/api_impl
+ use source && java-pkg_dosrc src/java/*
+}