summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-08-21 09:23:59 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-09-13 11:43:40 +0200
commit0dfcc0aea5249296731cb6a3de428e16d3585cf2 (patch)
tree6eca9cc139165cc96733c0741fd98e9ddfa94b72 /dev-java
parentdev-util/librnp: add another upstream issue link to 0.16.1 (diff)
downloadgentoo-0dfcc0aea5249296731cb6a3de428e16d3585cf2.tar.gz
gentoo-0dfcc0aea5249296731cb6a3de428e16d3585cf2.tar.bz2
gentoo-0dfcc0aea5249296731cb6a3de428e16d3585cf2.zip
dev-java/browserlauncher2: better handling of JAVA_ENCODING
* update EAPI 7 -> 8 * switch to java-pkg-simple * set JAVA_ENCODING="ISO-8859-1" instead of using iconv Bug: https://bugs.gentoo.org/835488 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26945 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/browserlauncher2/browserlauncher2-1.3-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/browserlauncher2/browserlauncher2-1.3-r3.ebuild b/dev-java/browserlauncher2/browserlauncher2-1.3-r3.ebuild
new file mode 100644
index 000000000000..a20e47279bc6
--- /dev/null
+++ b/dev-java/browserlauncher2/browserlauncher2-1.3-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A library that facilitates opening a browser from a Java application"
+HOMEPAGE="http://browserlaunch2.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/browserlaunch2/browserlauncher2/${PV}/BrowserLauncher2-all-${PV//./_}.jar"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/unzip"
+
+JAVA_SRC_DIR="source"
+JAVA_RESOURCE_DIRS="resources"
+JAVA_MAIN_CLASS="edu.stanford.ejalbert.testing.BrowserLauncherTestApp"
+JAVA_ENCODING="ISO-8859-1"
+
+src_prepare() {
+ default
+ java-pkg_clean
+
+ cp -r source resources || die "Cannot create resources dir"
+ find resources -type f ! -name '*.properties' -exec rm -rf {} + || die
+}