summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-08-23 08:16:47 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-09-17 14:47:16 +0200
commit137ce67be75c100f0d4e71bc695031641154be3d (patch)
tree0df9d62f18fc34f73aa5709c2358c3c3f7b4ae19 /dev-java
parentdev-java/scram: adjust MAVEN_ID (diff)
downloadgentoo-137ce67be75c100f0d4e71bc695031641154be3d.tar.gz
gentoo-137ce67be75c100f0d4e71bc695031641154be3d.tar.bz2
gentoo-137ce67be75c100f0d4e71bc695031641154be3d.zip
dev-java/jdbc-postgresql: add 42.5.0
We don't shade dependencies, they are all on classpath. A jar file for comparison can be obtained with "mvn -DskipShadeDependencies=true package" Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26972 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdbc-postgresql/Manifest1
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-42.5.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/jdbc-postgresql/Manifest b/dev-java/jdbc-postgresql/Manifest
index 4a263b6d3027..b8b5d45e578b 100644
--- a/dev-java/jdbc-postgresql/Manifest
+++ b/dev-java/jdbc-postgresql/Manifest
@@ -1 +1,2 @@
DIST postgresql-jdbc-42.4.1.src.tar.gz 969554 BLAKE2B 76035b2362c304d6263b9549b2ecbedc6e1cfedeba9c2c35f07d29dada39e5bce93e939abb8cb2232a428b0341c5cd5e6ae22de6106292c4d28243e3e0e6fc00 SHA512 a49c5b68a26ba6fd1b150c45da2ec58ea4435b7c36b8aa9bf6c3d33b6a265dabe7da51705e9d7234a640c8f6ccb5c3abb639db2d7bc38e6f4e26550b05b4a844
+DIST postgresql-jdbc-42.5.0.src.tar.gz 971368 BLAKE2B 961ba5af17f27792f44b715e8a248950926f1e7a384c3bb7ef4d9f919c84833129d45bcaeaded17d8d8cb3733b3f70cde76c126c501c7c1c1ed8a356c2e2f78d SHA512 432347622d6a1034048cb2dc18e7c5fdb1e843a27db505c8ea0381fee700480682222f4b8a285d8d774a0732398cc6254692c8f130c1814a464966b9dba72f64
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-42.5.0.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-42.5.0.ebuild
new file mode 100644
index 000000000000..52690c919d62
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-42.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://jdbc.postgresql.org/download/postgresql-jdbc-42.5.0.src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild jdbc-postgresql-42.5.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.postgresql:postgresql:42.5.0"
+# We don't have junit-vintage and junit-jupiter.
+# JAVA_TESTING_FRAMEWORKS="junit-vintage junit-jupiter junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java JDBC 4.2 (JRE 8+) driver for PostgreSQL database"
+HOMEPAGE="https://jdbc.postgresql.org/"
+SRC_URI="https://jdbc.postgresql.org/download/postgresql-jdbc-${PV}.src.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# com.ongres.scram:client:2.1 -> >=dev-java/scram-2.1:0
+# uk.org.webcompere:system-stubs-jupiter:2.0.1 -> !!!groupId-not-found!!!
+
+CP_DEPEND="dev-java/scram:0"
+
+# Compile dependencies
+# POM: pom.xml
+# test? junit:junit:4.13 -> >=dev-java/junit-4.13.2:4
+# test? org.junit.jupiter:junit-jupiter-api:5.8.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter-engine:5.8.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter-params:5.8.2 -> !!!groupId-not-found!!!
+# test? org.junit.vintage:junit-vintage-engine:5.8.2 -> !!!groupId-not-found!!!
+# test? se.jiderhamn:classloader-leak-test-framework:1.1.1 -> !!!groupId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CP_DEPEND}"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+S="${WORKDIR}/postgresql-${PV}-jdbc-src"
+
+JAVA_MAIN_CLASS="org.postgresql.util.PGJDBCMain"
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"