summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-23 12:24:04 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-23 12:31:43 +0100
commit1569bee32a7b244346f0fe4acb232d0c064c324e (patch)
tree24b4cf8204deaa8d2e47fd481ab8cf72990a0fe5 /dev-java
parentdev-perl/DBD-mysql: Bump to version 4.42.0 re bug #604678 (diff)
downloadgentoo-1569bee32a7b244346f0fe4acb232d0c064c324e.tar.gz
gentoo-1569bee32a7b244346f0fe4acb232d0c064c324e.tar.bz2
gentoo-1569bee32a7b244346f0fe4acb232d0c064c324e.zip
dev-java/jcifs: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jcifs/jcifs-1.3.17-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jcifs/jcifs-1.3.17-r2.ebuild b/dev-java/jcifs/jcifs-1.3.17-r2.ebuild
new file mode 100644
index 000000000000..d58c3b62d305
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.17-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="http://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="http://jcifs.samba.org/"
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+
+CDEPEND="java-virtuals/servlet-api:3.0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+JAVA_GENTOO_CLASSPATH="servlet-api-3.0"
+
+JAVA_SRC_DIR="src"
+
+DOCS=( README.txt )
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples examples
+ einstalldocs
+}