summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-08-05 12:03:20 -0400
committerFlorian Schmaus <flow@gentoo.org>2022-08-10 10:24:44 +0200
commit1a5069b33787fa5114814d70535bab4775c74fb7 (patch)
tree5442b2debbe7ec8d796336de8819d4be2fe4ca2b /dev-java
parentdev-java/byte-buddy: add 1.12.13 (diff)
downloadgentoo-1a5069b33787fa5114814d70535bab4775c74fb7.tar.gz
gentoo-1a5069b33787fa5114814d70535bab4775c74fb7.tar.bz2
gentoo-1a5069b33787fa5114814d70535bab4775c74fb7.zip
dev-java/java-service-wrapper: replace testsuite.patch with sed
java-service-wrapper-3.5.25-testsuite.patch should have been ported to 3.5.50 but wasn't. Since it's a trivial patch, rather than rebasing it each time, just replace with a sed. Closes: https://bugs.gentoo.org/863761 Signed-off-by: matoro <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/26749 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-service-wrapper/java-service-wrapper-3.5.50.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-java/java-service-wrapper/java-service-wrapper-3.5.50.ebuild b/dev-java/java-service-wrapper/java-service-wrapper-3.5.50.ebuild
index 149e25fdc514..40ab4cf7bcbd 100644
--- a/dev-java/java-service-wrapper/java-service-wrapper-3.5.50.ebuild
+++ b/dev-java/java-service-wrapper/java-service-wrapper-3.5.50.ebuild
@@ -47,7 +47,11 @@ src_prepare() {
cp "${S}/src/c/Makefile-linux-armel-32.make" "${S}/src/c/Makefile-linux-arm-32.make"
java-pkg-2_src_prepare
- # enable tests on all platforms
+ # disable tests by default (they are only enabled by default on amd64)
+ sed -e "s/\(all: init wrapper libwrapper.so\) testsuite/\1/g" \
+ -i src/c/Makefile-linux-x86-64.make || die
+
+ # re-enable tests on all platforms if requested
if use test; then
grep "testsuite_SOURCE" "src/c/Makefile-linux-x86-64.make" | tee -a src/c/Makefile-*.make
assert