summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-03 11:24:28 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-03 11:24:50 +0100
commita4698530c9e113a21f8124ea96b164fb7addc91b (patch)
tree09cee418d939012e8aea91f64c09de2e44af412c /dev-java
parentdev-ruby/test-unit: cleanup (diff)
downloadgentoo-a4698530c9e113a21f8124ea96b164fb7addc91b.tar.gz
gentoo-a4698530c9e113a21f8124ea96b164fb7addc91b.tar.bz2
gentoo-a4698530c9e113a21f8124ea96b164fb7addc91b.zip
dev-java/jempbox-1.{7.1,8.11}: removed old
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jempbox/jempbox-1.7.1.ebuild45
-rw-r--r--dev-java/jempbox/jempbox-1.8.11.ebuild45
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-java/jempbox/jempbox-1.7.1.ebuild b/dev-java/jempbox/jempbox-1.7.1.ebuild
deleted file mode 100644
index d5f8087253ab..000000000000
--- a/dev-java/jempbox/jempbox-1.7.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_PN=pdfbox
-
-DESCRIPTION="An open source Java library for parsing font files"
-HOMEPAGE="http://pdfbox.apache.org/"
-SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_PN}-${PV}-src.zip"
-
-LICENSE="BSD"
-SLOT="1.7"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- >=virtual/jre-1.5"
-DEPEND="
- >=virtual/jdk-1.5
- app-arch/unzip
- test? ( dev-java/ant-junit:0 )"
-
-S="${WORKDIR}/${MY_PN}-${PV}/${PN}"
-
-java_prepare() {
- cp -v "${FILESDIR}"/${P}_maven-build.xml build.xml || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar ${PN}.jar
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/org
-}
diff --git a/dev-java/jempbox/jempbox-1.8.11.ebuild b/dev-java/jempbox/jempbox-1.8.11.ebuild
deleted file mode 100644
index 7653bdb73e99..000000000000
--- a/dev-java/jempbox/jempbox-1.8.11.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_PN="pdfbox"
-MY_P="${MY_PN}-${PV}"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="An open source Java library for working with XMP metadata"
-HOMEPAGE="http://pdfbox.apache.org/"
-SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_P}-src.zip"
-LICENSE="Apache-2.0"
-SLOT="1.8"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
-IUSE="test"
-
-RDEPEND=">=virtual/jre-1.6"
-
-DEPEND=">=virtual/jdk-1.6
- app-arch/unzip
- test? ( dev-java/junit:4 )"
-
-S="${WORKDIR}/${MY_P}/${PN}"
-JAVA_SRC_DIR="src/main/java"
-
-src_install() {
- java-pkg-simple_src_install
- dodoc README.txt
-}
-
-src_test() {
- local DIR=src/test/java
- local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4)"
- local TESTS=$(find ${DIR} -name "*Test.java")
- TESTS="${TESTS//src\/test\/java\/}"
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
-
- ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
- ejunit4 -classpath "${CP}" ${TESTS}
-}