summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-06 10:01:52 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-10 08:39:51 +0200
commitc2ea91d73dcf7c8725f79e223d1faecb425499ba (patch)
tree81c278872a229a44b1d099da4eef81c30516b1bd /dev-java
parentapp-text/htp: version bump. (diff)
downloadgentoo-c2ea91d73dcf7c8725f79e223d1faecb425499ba.tar.gz
gentoo-c2ea91d73dcf7c8725f79e223d1faecb425499ba.tar.bz2
gentoo-c2ea91d73dcf7c8725f79e223d1faecb425499ba.zip
dev-java/commons-math: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-math/Manifest1
-rw-r--r--dev-java/commons-math/commons-math-3.6.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-java/commons-math/Manifest b/dev-java/commons-math/Manifest
index 44b31932130f..ff7a701a4109 100644
--- a/dev-java/commons-math/Manifest
+++ b/dev-java/commons-math/Manifest
@@ -1,2 +1,3 @@
DIST commons-math-2.1-src.tar.gz 1099423 BLAKE2B 83c52abc10eebb6c749aec218aa435df4cd05106e6bcbead5061df7381d168aa9392ab70dce8eb0b8e254d6d95a372cacddc8f7714198a186a95a04a394bda9d SHA512 53ed8c0400402c588d824c15365ebe60bef41697ff9728270a9fdc3ac30eb60c4c397caf939ccda839eb701453d98af4eac9eae2090575fcfdee4df2d6f6045b
DIST commons-math3-3.2-src.tar.gz 2602474 BLAKE2B a818ca5ab1b9799359bad1c84d2774329c7c2605aeea3e13769eed9f1578d412555ad90a8de68971daa42b270d4bcd5fbf0fe79714e839d41b08077e32633125 SHA512 132c4725be582e25f67a955c7b3b8c7ef155606d8f4da07770464c422ded6b5e6efd1a13a6e98cff222f4fcac73606d512ee1ab9e3b1c4befcc1ba16ab68787b
+DIST commons-math3-3.6.1.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
diff --git a/dev-java/commons-math/commons-math-3.6.1.ebuild b/dev-java/commons-math/commons-math-3.6.1.ebuild
new file mode 100644
index 000000000000..5578f6ffa3a0
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="https://commons.apache.org/math/"
+SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar
+-> ${MY_P}.jar"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"