summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-05-26 08:13:28 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-27 18:30:27 +0200
commitd3285a05976493a68d7e228f8f6e5e5c54104678 (patch)
tree2d919fa61d326762454a600c3839dea73c1b1b58 /dev-java
parentdev-java/cssparser: clean up old versions. (diff)
downloadgentoo-d3285a05976493a68d7e228f8f6e5e5c54104678.tar.gz
gentoo-d3285a05976493a68d7e228f8f6e5e5c54104678.tar.bz2
gentoo-d3285a05976493a68d7e228f8f6e5e5c54104678.zip
dev-java/commons-codec: version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-codec/Manifest1
-rw-r--r--dev-java/commons-codec/commons-codec-1.11.ebuild54
-rw-r--r--dev-java/commons-codec/files/commons-codec-1.11-build.xml200
3 files changed, 255 insertions, 0 deletions
diff --git a/dev-java/commons-codec/Manifest b/dev-java/commons-codec/Manifest
index 0150168c64c1..ac0569a673cc 100644
--- a/dev-java/commons-codec/Manifest
+++ b/dev-java/commons-codec/Manifest
@@ -1 +1,2 @@
+DIST commons-codec-1.11.tar.gz 369538 BLAKE2B 6b77cb3c69c81a9684b298ac5233b788d6651ecc96b70ac7fda9face5af5a60970c5bb2531fd285d20dce7732829f7470b9e4941d63025faf47247410f1ffba2 SHA512 b3159308f28b2fc50208421412d8cc81f439cc07dc3d071df7b50f2d862aab65b3d20bc8eb2906367a05ecf5138c56b5f12c6cf9c224def8b8286fe12ac5346f
DIST commons-codec-1.7-src.tar.gz 291251 BLAKE2B b8fecdb9b88a21ceb3106a13332493617ecd2c8064c84a1514dec1c1c254e18116ff4926f7445bef4171000ba77da411efd6a93fe80a4795e887832035373e10 SHA512 31358283ac2827cb05486b8ff1512242153f61deb086f7fe145ee3ca38d96e43fba080a1e89a3b8cd44d09761015ff4dbe5226d29b7f9fcd59e68ca7701b28d6
diff --git a/dev-java/commons-codec/commons-codec-1.11.ebuild b/dev-java/commons-codec/commons-codec-1.11.ebuild
new file mode 100644
index 000000000000..7abed459fb4e
--- /dev/null
+++ b/dev-java/commons-codec/commons-codec-1.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementations of common encoders and decoders in Java"
+HOMEPAGE="https://commons.apache.org/codec"
+SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+RESTRICT="test"
+
+DOCS=( RELEASE-NOTES.txt NOTICE.txt )
+
+src_prepare() {
+ cp "${FILESDIR}/${P}-build.xml" "${S}/build.xml" || die
+ default
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${P}.jar"
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-codec/files/commons-codec-1.11-build.xml b/dev-java/commons-codec/files/commons-codec-1.11-build.xml
new file mode 100644
index 000000000000..251268136bf8
--- /dev/null
+++ b/dev-java/commons-codec/files/commons-codec-1.11-build.xml
@@ -0,0 +1,200 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/27/18 9:10 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-codec-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-codec-1.11"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.12/junit-4.12.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/commons/commons-lang3/3.5/commons-lang3-3.5.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*AbstractTest.java"/>
+ <exclude name="**/*PerformanceTest.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*AbstractTest.java"/>
+ <exclude name="**/*PerformanceTest.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ docencoding="UTF-8"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://docs.oracle.com/javase/7/docs/api/"/>
+ <link href="http://docs.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <!--
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="/var/tmp/portage/dev-java/commons-codec-1.11/work/commons-codec-1.11-src/target/osgi/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class"/>
+ </manifest>
+ </jar>
+ </target>
+ -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+</project>