summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-08-31 23:07:52 +0100
committerJames Le Cuirot <chewi@gentoo.org>2015-08-31 23:43:06 +0100
commitde71cda628e067db144e1977e0c31c017b329853 (patch)
treebd114a6258a6d6140ea9580fc0980e4b6bb8d54c /dev-java
parentmedia-fonts/kanjistrokeorders: Remove old (diff)
downloadgentoo-de71cda628e067db144e1977e0c31c017b329853.tar.gz
gentoo-de71cda628e067db144e1977e0c31c017b329853.tar.bz2
gentoo-de71cda628e067db144e1977e0c31c017b329853.zip
dev-java/java-sdk-docs: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/Manifest1
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.60.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/Manifest b/dev-java/java-sdk-docs/Manifest
index 82724982be41..ce25682f937f 100644
--- a/dev-java/java-sdk-docs/Manifest
+++ b/dev-java/java-sdk-docs/Manifest
@@ -1,3 +1,4 @@
DIST jdk-6u30-apidocs.zip 59086542 SHA256 92739c56e02fa6e7ac8d60a1f59a0ef4a59ac99ab2979d3cdc495bfecf1a50ab SHA512 5139b1a65765f258f21c629a0cfbf07aed0c12b3eb08d4615b049e825abd90c5b3385af99dba3a4ac6e0a94a5ffaa32ee648fb3e7ac1815ec6b74fe0d8e9f0ee WHIRLPOOL 941236c68b189f9cd23f0e904cc01da9f87cc39967c84cddf4c20a04fa2872eb99af147a21bb770320cad28b2cd86205402a141f7217d5301fa9a6ea41c3a136
DIST jdk-7u80-docs-all.zip 61168809 SHA256 0494bd49bc9cb3cbe3203120ae8b2c8e0aeb1579cb15c0fbd3cd780d19aa200a SHA512 c673c00e55c9a19938c42512cb9c6ae65de9803a1307d11a2043903d87cc36d9ed1f5a1e287040d8570e430cfe55f496354c1242fe6e242f1245f8271394ea1a WHIRLPOOL ad18886c401ec42735665081a0dd5ba3dc7678de0171f3aa8151c2e4ce3392e467be65c602f393da38373e589fa9800ed1afd3601d2cef4e48b06e57f491698e
DIST jdk-8u51-docs-all.zip 92230995 SHA256 fa36f0611df525b39e27353daa42b089dc76f86f7dc09b0dc98d72c10ba76284 SHA512 bb1e65820902153d2fbebc170b18bce0c630dc8b5ce70fde53f6b55f9203267411846b9c81a77fb0c45f30df30f4d327120499c3ad11dc8e50c078d096e1943f WHIRLPOOL dd0e6b2dfbd8ce9960359013ace595c50c7281e8bed3e7cbc2a93f6a776eb4d60ecbc7d2a16796eefca02d38af3fcee9b4633215288ce464fed852e147599a50
+DIST jdk-8u60-docs-all.zip 92340397 SHA256 cbeffb41253da58f8924423f22a9bd53802633925664d68c46e6bfffd506a33d SHA512 cd728d1eda4bbe5dea98da693b8b173e3b05d431b9ba5be2c55dfa60f141941d7131b76785f37f52fe4a027224ff6a87394f5fe565666b581accfc38fc480ecb WHIRLPOOL 646925a3d7bb079056b8fcb51be1138214c1de3495188d08c00b4b9380f0de93e5b2a4988d0c028cbf07868b4bd296656813d7b19e6f8ba48965a36dc6f1180d
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.60.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.60.ebuild
new file mode 100644
index 000000000000..d9afbf512c90
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.60.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}