summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBobbbay Bobbayan <abatterysingle@gmail.com>2020-08-31 09:07:39 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-10-02 11:42:30 +0300
commit11667a05665c314527ccd78ff027e83f11c52d35 (patch)
tree8f228a7cd14de36446e19e98a44b0942e0ac8ceb /dev-lang/coffee-script
parentapp-crypt/tpm2-totp: Remove old (diff)
downloadgentoo-11667a05665c314527ccd78ff027e83f11c52d35.tar.gz
gentoo-11667a05665c314527ccd78ff027e83f11c52d35.tar.bz2
gentoo-11667a05665c314527ccd78ff027e83f11c52d35.zip
dev-lang/coffee-script: version bump to 2.5.1
As well as some other touchups Signed-off-by: Bobbbay Bobbayan <abatterysingle@gmail.com> Package-Manager: Portage-3.0.4, Repoman-2.3.23 Closes: https://github.com/gentoo/gentoo/pull/17346 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/coffee-script')
-rw-r--r--dev-lang/coffee-script/Manifest1
-rw-r--r--dev-lang/coffee-script/coffee-script-2.5.1.ebuild52
-rw-r--r--dev-lang/coffee-script/metadata.xml5
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-lang/coffee-script/Manifest b/dev-lang/coffee-script/Manifest
index de8c29ca0a30..45e9c619a2ff 100644
--- a/dev-lang/coffee-script/Manifest
+++ b/dev-lang/coffee-script/Manifest
@@ -1,3 +1,4 @@
DIST coffee-script-1.12.5.tar.gz 1429494 BLAKE2B b64dc0dce9d2dbcbe5e20fcf002e9fe12116e6987ebdb19c82dadec61d90eaf66de5f4560bab5a3df1c8cef9f557bb0f5c5edd3e1fa5e7062cc0641dcbec28bc SHA512 b83981508c99e52957786d66b6c93e65cea98386b247cddfd516146eb4edb7ccb49451cc976d683fc9127b1ed0ea0a4d54cc47be519af1bf9e8b3dd79159d591
DIST coffee-script-1.9.3.tar.gz 810246 BLAKE2B dbca1d690ad80e38d8997c237f8c4c6e8a6b8d5c1362d5173a0c38d75e1389f5d8c09299bbb4902745e77133901857c8c15cec0dc17cbb883acf84854aefb68f SHA512 660826e27f842ed67ec6ef59f734087c95585e03b6b8c6d25c8ecfc567f3161f59034e730b61e5f806edaaa7ec6c805ad6d14902857aaf09cf6193b0fe14f506
DIST coffee-script-2.3.2.tar.gz 1754957 BLAKE2B 7a276a16f4db9c2f53258161af0cb1cebd71fac6acca94d5ee5b0a67e1d59d17ffca8b98f20b3afbe30297963dfa683af16ae01bf0ed6eda49a20a858f6d4850 SHA512 ab50737ffd46db007fc98cbba5ef1fc6c97b20a40b848f9635282ddf19188c59172f984bd62b345b6aae96a92af3ac046cedb568c16db2a5e29d287314e13cd5
+DIST coffee-script-2.5.1.tar.gz 2226483 BLAKE2B 5a2c5f93d46b111aeda63077f60992232a768008187ba0e41bec885184fbbbb91014620fca5d8e38cfdb5e88de483425d3d95c87779f27d7450de7cbe62b489b SHA512 99f11f0822ffc841552cf6c78a28d152554f070df6d1b729bdd17df8ba6faae6ed2ba9886f7ee13ccb316de698ab8624370287274611fe90bef033d9f76c5865
diff --git a/dev-lang/coffee-script/coffee-script-2.5.1.ebuild b/dev-lang/coffee-script/coffee-script-2.5.1.ebuild
new file mode 100644
index 000000000000..ce12a698c64d
--- /dev/null
+++ b/dev-lang/coffee-script/coffee-script-2.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="coffeescript"
+
+DESCRIPTION="A little language that compiles into javascript"
+HOMEPAGE="https://coffeescript.org/"
+SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# This package has a test suite (that works), but it requires a number
+# of NodeJS/NPM packages that aren't in the tree.
+IUSE="doc examples"
+
+RDEPEND="net-libs/nodejs"
+
+src_install() {
+ local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
+ insinto "${npm_module_dir}"
+ doins *.js package.json
+ doins -r lib
+ dodoc CONTRIBUTING.md README.md
+
+ if use examples; then
+ # Users should be able to run the examples without having to copy
+ # them to another directory and decompress them.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r documentation/examples
+ fi
+
+ if use doc; then
+ # It looks like "docs/v2" contains the output from all of the stuff
+ # under "documentation".
+ docinto "html"
+ dodoc -r docs/v2/*
+ fi
+
+ # The coffee and cake "binaries" use a relative path to find the lib
+ # directory, so we have to symlink them rather than use dobin().
+ exeinto "${npm_module_dir}/bin"
+ doexe bin/cake
+ doexe bin/coffee
+ dosym "${npm_module_dir}/bin/cake" "/usr/bin/cake"
+ dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
+}
diff --git a/dev-lang/coffee-script/metadata.xml b/dev-lang/coffee-script/metadata.xml
index ccff50578dc8..cd39081640ef 100644
--- a/dev-lang/coffee-script/metadata.xml
+++ b/dev-lang/coffee-script/metadata.xml
@@ -5,4 +5,9 @@
<upstream>
<remote-id type="github">jashkenas/coffeescript</remote-id>
</upstream>
+ <longdescription>
+ CoffeeScript is a little language that compiles into JavaScript. Underneath that awkward Java-esque patina, JavaScript has always had a gorgeous heart. CoffeeScript is an attempt to expose the good parts of JavaScript in a simple way.
+
+ The golden rule of CoffeeScript is: "It's just JavaScript." The code compiles one-to-one into the equivalent JS, and there is no interpretation at runtime. You can use any existing JavaScript library seamlessly from CoffeeScript (and vice-versa). The compiled output is readable, pretty-printed, and tends to run as fast or faster than the equivalent handwritten JavaScript.
+ </longdescription>
</pkgmetadata>