summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-28 12:26:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-28 12:48:22 +0000
commitef80935bdf6325a68ed25e5a94ae602227402cd2 (patch)
tree9e2660319bde9eea80276a0ad9ca3bc404736088 /dev-lang/crystal/files
parentprofiles: mask USE=valgrind on arm64, not tested yet (diff)
downloadgentoo-ef80935bdf6325a68ed25e5a94ae602227402cd2.tar.gz
gentoo-ef80935bdf6325a68ed25e5a94ae602227402cd2.tar.bz2
gentoo-ef80935bdf6325a68ed25e5a94ae602227402cd2.zip
dev-lang/crystal: respect CC/CXX/AR/MAKEOPTS, bug #607468
While at it enabled a few verbosity flags to make build slightly more chatty. Reported-by: Michał Górny Bug: https://bugs.gentoo.org/607468 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang/crystal/files')
-rw-r--r--dev-lang/crystal/files/crystal-0.20.5-AR.patch9
-rw-r--r--dev-lang/crystal/files/crystal-0.20.5-verbose.patch9
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-lang/crystal/files/crystal-0.20.5-AR.patch b/dev-lang/crystal/files/crystal-0.20.5-AR.patch
new file mode 100644
index 000000000000..950bc23a157a
--- /dev/null
+++ b/dev-lang/crystal/files/crystal-0.20.5-AR.patch
@@ -0,0 +1,9 @@
+diff --git a/Makefile b/Makefile
+index dc675a0..1f53d40 100644
+--- a/Makefile
++++ b/Makefile
+@@ -118,3 +118,3 @@ $(LLVM_EXT_OBJ): $(LLVM_EXT_DIR)/llvm_ext.cc
+ $(LIB_CRYSTAL_TARGET): $(LIB_CRYSTAL_OBJS)
+- ar -rcs $@ $^
++ $(AR) -rcs $@ $^
+
diff --git a/dev-lang/crystal/files/crystal-0.20.5-verbose.patch b/dev-lang/crystal/files/crystal-0.20.5-verbose.patch
new file mode 100644
index 000000000000..6a0a301b5c02
--- /dev/null
+++ b/dev-lang/crystal/files/crystal-0.20.5-verbose.patch
@@ -0,0 +1,9 @@
+diff --git a/Makefile b/Makefile
+index 1f53d40..fa71479 100644
+--- a/Makefile
++++ b/Makefile
+@@ -24,3 +24,3 @@ SOURCES := $(shell find src -name '*.cr')
+ SPEC_SOURCES := $(shell find spec -name '*.cr')
+-FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(threads),--threads $(threads) )$(if $(debug),-d )
++FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(verbose),--verbose )
+ VERBOSE := $(if $(verbose),-v )