summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/gforth/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/gforth/files')
-rw-r--r--dev-lang/gforth/files/0.6.2-c-to-forth-to-c.patch30
-rw-r--r--dev-lang/gforth/files/0.6.2-ppc-configure-gentoo.patch13
-rw-r--r--dev-lang/gforth/files/50gforth-gentoo.el7
-rw-r--r--dev-lang/gforth/files/gforth-0.7.0-make-elc.patch14
-rw-r--r--dev-lang/gforth/files/gforth.el-gentoo.patch37
5 files changed, 101 insertions, 0 deletions
diff --git a/dev-lang/gforth/files/0.6.2-c-to-forth-to-c.patch b/dev-lang/gforth/files/0.6.2-c-to-forth-to-c.patch
new file mode 100644
index 000000000000..28ab2e5f572f
--- /dev/null
+++ b/dev-lang/gforth/files/0.6.2-c-to-forth-to-c.patch
@@ -0,0 +1,30 @@
+Index: engine/main.c
+===================================================================
+RCS file: /usr/local/lib/cvs-repository/src-master/gforth/engine/main.c,v
+retrieving revision 1.139
+retrieving revision 1.140
+diff -u -r1.139 -r1.140
+--- engine/main.c.old 2004/01/20 19:07:41 1.139
++++ engine/main.c 2004/04/10 00:16:55 1.140
+@@ -70,8 +70,21 @@
+
+ void engine_callback(Xt* fcall, void * alist)
+ {
++ /* save global valiables */
++ Cell *rp = RP;
++ Cell *sp = SP;
++ Float *fp = FP;
++ Address lp = LP;
++
+ clist = (va_alist)alist;
+- engine(fcall, SP, RP, FP, LP);
++
++ engine(fcall, sp, rp, fp, lp);
++
++ /* restore global variables */
++ RP = rp;
++ SP = sp;
++ FP = fp;
++ LP = lp;
+ }
+ #endif \ No newline at end of file
diff --git a/dev-lang/gforth/files/0.6.2-ppc-configure-gentoo.patch b/dev-lang/gforth/files/0.6.2-ppc-configure-gentoo.patch
new file mode 100644
index 000000000000..30061aa702f7
--- /dev/null
+++ b/dev-lang/gforth/files/0.6.2-ppc-configure-gentoo.patch
@@ -0,0 +1,13 @@
+diff -ur gforth-0.6.2.orig/configure gforth-0.6.2/configure
+--- gforth-0.6.2.orig/configure 2003-08-25 03:03:42.000000000 -0500
++++ gforth-0.6.2/configure 2006-05-12 15:10:52.000000000 -0500
+@@ -3586,7 +3586,8 @@
+ fi
+
+ #long long is broken on (at least) gcc-2.95.* for PPC
+- test x$ac_cv_sizeof_long_long = x && ac_cv_sizeof_long_long=0
++ # XXX this was fixed long ago
++# test x$ac_cv_sizeof_long_long = x && ac_cv_sizeof_long_long=0
+ ;;
+ *)
+ { echo "$as_me:$LINENO: WARNING: Using a generic machine description" >&5
diff --git a/dev-lang/gforth/files/50gforth-gentoo.el b/dev-lang/gforth/files/50gforth-gentoo.el
new file mode 100644
index 000000000000..b2be92698bbb
--- /dev/null
+++ b/dev-lang/gforth/files/50gforth-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; gforth site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'forth-mode "gforth" "Autoload for `forth-mode'." t)
+(autoload 'run-forth "gforth" "Autoload for `run-forth'." t)
diff --git a/dev-lang/gforth/files/gforth-0.7.0-make-elc.patch b/dev-lang/gforth/files/gforth-0.7.0-make-elc.patch
new file mode 100644
index 000000000000..fa558407c258
--- /dev/null
+++ b/dev-lang/gforth/files/gforth-0.7.0-make-elc.patch
@@ -0,0 +1,14 @@
+--- gforth-0.7.0-orig/Makefile.in
++++ gforth-0.7.0/Makefile.in
+@@ -430,7 +430,10 @@
+
+ ENGINES_FAST = gforth-fast$(OPT)$(EC)$(EXE) #gforth-native$(OPT)$(EC)$(EXE)
+
+-GEN = $(ENGINES) $(ENGINES_FAST) gforth.elc
++GEN = $(ENGINES) $(ENGINES_FAST)
++ifneq ($(emacssitelispdir), no)
++GEN += gforth.elc
++endif
+
+ # things that need a working forth system to be generated
+ FORTH_GEN_ENGINE=engine/prim.i engine/prim_lab.i engine/prim_names.i \
diff --git a/dev-lang/gforth/files/gforth.el-gentoo.patch b/dev-lang/gforth/files/gforth.el-gentoo.patch
new file mode 100644
index 000000000000..cc98537e766d
--- /dev/null
+++ b/dev-lang/gforth/files/gforth.el-gentoo.patch
@@ -0,0 +1,37 @@
+--- gforth-0.6.2-orig/gforth.el 2003-08-05 11:12:47.000000000 +0200
++++ gforth-0.6.2/gforth.el 2008-09-06 08:29:44.000000000 +0200
+@@ -61,9 +61,10 @@
+ (progn (string-match "^[0-9]+" emacs-version)
+ (string-to-int (match-string 0 emacs-version)))))
+
+-(defun forth-emacs-older (major minor)
+- (or (< emacs-major-version major)
+- (and (= emacs-major-version major) (< emacs-minor-version minor))))
++(eval-when-compile
++ (defun forth-emacs-older (major minor)
++ (or (< emacs-major-version major)
++ (and (= emacs-major-version major) (< emacs-minor-version minor)))))
+
+ ;; Code ripped from `subr.el' for compatability with Emacs versions
+ ;; prior to 20.1
+@@ -79,8 +80,9 @@
+
+ ;; `no-error' argument of require not supported in Emacs versions
+ ;; prior to 20.4 :-(
+-(defun forth-require (feature)
+- (condition-case err (require feature) (error nil)))
++(eval-and-compile
++ (defun forth-require (feature)
++ (condition-case err (require feature) (error nil))))
+
+ (require 'font-lock)
+
+@@ -1702,6 +1704,6 @@
+ (error "No current process. See variable `forth-process-buffer'"))))
+ ) ; (memq 'comint features)
+
+-(provide 'forth-mode)
++(provide 'gforth)
+
+ ;;; gforth.el ends here
+