summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-05 09:09:21 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-05 09:09:38 +0100
commite40aad97e99802d7ea05f6046940418f8f34c008 (patch)
treed0a02f9d20a9bb31efde53072da1771828f9b545 /dev-lang/gforth
parentdev-lang/erlang: run configure in serial (diff)
downloadgentoo-e40aad97e99802d7ea05f6046940418f8f34c008.tar.gz
gentoo-e40aad97e99802d7ea05f6046940418f8f34c008.tar.bz2
gentoo-e40aad97e99802d7ea05f6046940418f8f34c008.zip
dev-lang/gforth: add a hack for slibtool
For library building gforth relies on a `libtool` binary to be present at runtime. Reported-by: Alessandro Barbieri Closes: https://bugs.gentoo.org/799371 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/gforth')
-rw-r--r--dev-lang/gforth/gforth-0.7.3-r2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-lang/gforth/gforth-0.7.3-r2.ebuild b/dev-lang/gforth/gforth-0.7.3-r2.ebuild
index 874e12892beb..dfd7e9a7b684 100644
--- a/dev-lang/gforth/gforth-0.7.3-r2.ebuild
+++ b/dev-lang/gforth/gforth-0.7.3-r2.ebuild
@@ -30,6 +30,15 @@ PATCHES=(
src_prepare() {
default
+ # gforth uses both $LIBTOOL and $GNU_LIBTOOL.
+ # Let's settle on the former: bug #799371
+ if [[ -n $LIBTOOL ]]; then
+ export GNU_LIBTOOL=$LIBTOOL
+ # ./configure does not generate it, but slibtool assumes
+ # it's around
+ ln -s ${EPREFIX}/usr/bin/libtool libtool || die
+ fi
+
# We patches both configure and configure.ac.
# Avoid reruining aclocal.
touch aclocal.m4 configure || die