summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-07-17 22:05:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-07-17 22:05:33 +0100
commita5434e5130e1cde63875406c47abda480646f22e (patch)
tree1b2d2417402af4068ee55e0831ab8802c35ad68d /dev-lang/ghc/ghc-8.6.5.ebuild
parentmedia-gfx/ristretto: Bump to 0.8.5 (diff)
downloadgentoo-a5434e5130e1cde63875406c47abda480646f22e.tar.gz
gentoo-a5434e5130e1cde63875406c47abda480646f22e.tar.bz2
gentoo-a5434e5130e1cde63875406c47abda480646f22e.zip
dev-lang/ghc: add amd64 and x86 binaries
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/ghc/ghc-8.6.5.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.6.5.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-lang/ghc/ghc-8.6.5.ebuild b/dev-lang/ghc/ghc-8.6.5.ebuild
index 04327fdfc430..379ebf395c3a 100644
--- a/dev-lang/ghc/ghc-8.6.5.ebuild
+++ b/dev-lang/ghc/ghc-8.6.5.ebuild
@@ -27,12 +27,12 @@ BIN_PV=${PV}
#arch_binaries="$arch_binaries alpha? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-alpha.tbz2 )"
#arch_binaries="$arch_binaries arm? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-armv7a-hardfloat-linux-gnueabi.tbz2 )"
#arch_binaries="$arch_binaries arm64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-aarch64-unknown-linux-gnu.tbz2 )"
-#arch_binaries="$arch_binaries amd64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86_64-pc-linux-gnu.tbz2 )"
+arch_binaries="$arch_binaries amd64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86_64-pc-linux-gnu.tbz2 )"
#arch_binaries="$arch_binaries ia64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
#arch_binaries="$arch_binaries ppc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ppc.tbz2 )"
#arch_binaries="$arch_binaries ppc64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ppc64.tbz2 )"
#arch_binaries="$arch_binaries sparc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-sparc.tbz2 )"
-#arch_binaries="$arch_binaries x86? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
+arch_binaries="$arch_binaries x86? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
# various ports:
#arch_binaries="$arch_binaries x86-fbsd? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86-fbsd.tbz2 )"
@@ -43,12 +43,12 @@ yet_binary() {
#alpha) return 0 ;;
#arm64) return 0 ;;
#arm) return 0 ;;
- #amd64) return 0 ;;
+ amd64) return 0 ;;
#ia64) return 0 ;;
#ppc) return 0 ;;
#ppc64) return 0 ;;
#sparc) return 0 ;;
- #x86) return 0 ;;
+ x86) return 0 ;;
*) return 1 ;;
esac
}
@@ -71,7 +71,8 @@ BUMP_LIBRARIES=(
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS=""
+# to be rekeyworded when most of revdeps are updated
+#KEYWORDS="~amd64 ~x86"
IUSE="doc ghcbootstrap ghcmakebinary +gmp profile test"
IUSE+=" binary"