summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen L Arnold <nerdboy@gentoo.org>2017-03-14 14:21:45 -0700
committerStephen L Arnold <nerdboy@gentoo.org>2017-03-14 14:21:45 -0700
commita6aac9a2ab28c59f00a154cd61bd5c070f05bfd9 (patch)
treea04b2393d1130890a000ee7baeb8f8f18ee350e9 /dev-lang/gnat-gcc
parentsys-apps/man-pages: block older keyutils that install colliding man pages #61... (diff)
downloadgentoo-a6aac9a2ab28c59f00a154cd61bd5c070f05bfd9.tar.gz
gentoo-a6aac9a2ab28c59f00a154cd61bd5c070f05bfd9.tar.bz2
gentoo-a6aac9a2ab28c59f00a154cd61bd5c070f05bfd9.zip
dev-lang/gnat-gcc: add missing patch for gnatbuild-r1
This fixes bug 603790 - missing patch fail Reported-by: Michael Mounteney Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang/gnat-gcc')
-rw-r--r--dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch b/dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch
new file mode 100644
index 000000000000..0c197a15c134
--- /dev/null
+++ b/dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch
@@ -0,0 +1,27 @@
+--- gcc/Makefile.in.orig 2016-05-20 15:01:04.277726220 -0700
++++ gcc/Makefile.in 2016-05-20 18:40:43.658617109 -0700
+@@ -594,9 +594,9 @@
+ # --------
+
+ # Directory in which the compiler finds libraries etc.
+-libsubdir = $(libdir)/gcc/$(target_noncanonical)/$(version)
++libsubdir = $(libdir)/gnat-gcc/$(target_noncanonical)/SLOT_MARKER
+ # Directory in which the compiler finds executables
+-libexecsubdir = $(libexecdir)/gcc/$(target_noncanonical)/$(version)
++libexecsubdir = $(libexecdir)/gnat-gcc/$(target_noncanonical)/SLOT_MARKER
+ # Directory in which all plugin resources are installed
+ plugin_resourcesdir = $(libsubdir)/plugin
+ # Directory in which plugin headers are installed
+@@ -1944,9 +1944,9 @@
+
+ DRIVER_DEFINES = \
+ -DSTANDARD_STARTFILE_PREFIX=\"$(unlibsubdir)/\" \
+- -DSTANDARD_EXEC_PREFIX=\"$(libdir)/gcc/\" \
+- -DSTANDARD_LIBEXEC_PREFIX=\"$(libexecdir)/gcc/\" \
+- -DDEFAULT_TARGET_VERSION=\"$(version)\" \
++ -DSTANDARD_EXEC_PREFIX=\"$(libdir)/gnat-gcc/\" \
++ -DSTANDARD_LIBEXEC_PREFIX=\"$(libexecdir)/gnat-gcc/\" \
++ -DDEFAULT_TARGET_VERSION=\"SLOT_MARKER\" \
+ -DDEFAULT_TARGET_MACHINE=\"$(target_noncanonical)\" \
+ -DSTANDARD_BINDIR_PREFIX=\"$(bindir)/\" \
+ -DTOOLDIR_BASE_PREFIX=\"$(libsubdir_to_prefix)$(prefix_to_exec_prefix)\" \