summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-04-28 13:25:28 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-04-28 13:25:55 -0500
commit513cdb5d7b589bdb2d5d9fc4c0f7ce2606854328 (patch)
treeee2ad5c2ce60af3caede0f0141f6e55c1d05236a /dev-lang/go/go-9999.ebuild
parentprofiles/base/package.use.mask: add masks to mozilla ebuilds (diff)
downloadgentoo-513cdb5d7b589bdb2d5d9fc4c0f7ce2606854328.tar.gz
gentoo-513cdb5d7b589bdb2d5d9fc4c0f7ce2606854328.tar.bz2
gentoo-513cdb5d7b589bdb2d5d9fc4c0f7ce2606854328.zip
dev-lang/go: sync live ebuild
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/go/go-9999.ebuild')
-rw-r--r--dev-lang/go/go-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 85536d0dc700..88dace64fdc2 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -24,7 +24,10 @@ kernel_linux? (
amd64? ( ${BOOTSTRAP_DIST}/go-linux-amd64-bootstrap.tbz )
arm? ( ${BOOTSTRAP_DIST}/go-linux-arm-bootstrap.tbz )
arm64? ( ${BOOTSTRAP_DIST}/go-linux-arm64-bootstrap.tbz )
- ppc64? ( ${BOOTSTRAP_DIST}/go-linux-ppc64-bootstrap.tbz )
+ ppc64? (
+ ${BOOTSTRAP_DIST}/go-linux-ppc64-bootstrap.tbz
+ ${BOOTSTRAP_DIST}/go-linux-ppc64le-bootstrap.tbz
+ )
x86? ( ${BOOTSTRAP_DIST}/go-linux-386-bootstrap-1.tbz )
)
kernel_SunOS? (
@@ -38,8 +41,6 @@ if [[ ${PV} = 9999 ]]; then
inherit git-r3
else
SRC_URI+="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz"
- # go-bootstrap-1.4 only supports go on amd64, arm and x86 architectures.
- # Allowing other bootstrap options would enable arm64 and ppc64 builds.
case ${PV} in
*9999*|*_rc*) ;;
*)
@@ -87,6 +88,8 @@ go_arch()
case "${portage_arch}" in
x86) echo 386;;
x64-*) echo amd64;;
+ ppc64)
+ [[ "$(tc-endian)" = big ]] && echo ppc64 || echo ppc64le ;;
*) echo "${portage_arch}";;
esac
}
@@ -174,6 +177,7 @@ src_compile()
if [[ ${ARCH} == arm ]]; then
export GOARM=$(go_arm)
fi
+ elog "GOROOT_BOOTSTRAP is ${GOROOT_BOOTSTRAP}"
cd src
./make.bash || die "build failed"