summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-12-30 10:02:06 +0100
committerPatrick Lauer <patrick@gentoo.org>2015-12-30 10:02:06 +0100
commitde52f18b6d97e54185fd59b1ded63909f46410bf (patch)
tree2be5ec04250f2b4763214ac84a5ef9c026f10f31 /dev-lang/hy/hy-0.11.1.ebuild
parentprofiles/package.mask: remove bundler mask (diff)
downloadgentoo-de52f18b6d97e54185fd59b1ded63909f46410bf.tar.gz
gentoo-de52f18b6d97e54185fd59b1ded63909f46410bf.tar.bz2
gentoo-de52f18b6d97e54185fd59b1ded63909f46410bf.zip
dev-lang/hy: Bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/hy/hy-0.11.1.ebuild')
-rw-r--r--dev-lang/hy/hy-0.11.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-lang/hy/hy-0.11.1.ebuild b/dev-lang/hy/hy-0.11.1.ebuild
new file mode 100644
index 000000000000..5261e9d2f577
--- /dev/null
+++ b/dev-lang/hy/hy-0.11.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python2_7 python3_3 python3_4)
+
+inherit distutils-r1 eutils
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc examples"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/astor-0.5[${PYTHON_USEDEP}]
+ dev-python/clint[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+src_prepare() {
+ use examples && EXAMPLES=( eg/. )
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}