summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-01-28 21:23:47 +0100
committerPatrick Lauer <patrick@gentoo.org>2017-01-28 21:24:01 +0100
commit33b9daf7ec385e0146e0dc1f8f4ab99c8e11b43f (patch)
tree6d9465682b2bc4a7292df70f35b2be91c29284a5 /dev-lang/hy/hy-0.12.0.ebuild
parentdev-ros/gazebo_ros_control: Add := dep on gazebo (diff)
downloadgentoo-33b9daf7ec385e0146e0dc1f8f4ab99c8e11b43f.tar.gz
gentoo-33b9daf7ec385e0146e0dc1f8f4ab99c8e11b43f.tar.bz2
gentoo-33b9daf7ec385e0146e0dc1f8f4ab99c8e11b43f.zip
dev-lang/hy: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang/hy/hy-0.12.0.ebuild')
-rw-r--r--dev-lang/hy/hy-0.12.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-lang/hy/hy-0.12.0.ebuild b/dev-lang/hy/hy-0.12.0.ebuild
new file mode 100644
index 000000000000..38c03bca4df8
--- /dev/null
+++ b/dev-lang/hy/hy-0.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+inherit distutils-r1 eutils
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc examples"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/astor-0.5[${PYTHON_USEDEP}]
+ dev-python/clint[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+src_prepare() {
+ use examples && EXAMPLES=( eg/. )
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}