summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:19 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:19 +0100
commit4d77d73ec96a181ce2a2441f299e3f6ab0d20ccd (patch)
tree155ef4f8f37e51e631512c9e8e69ab409b1e586b /dev-lang/hy/hy-0.12.0.ebuild
parentapp-text/doconce: Remove old (diff)
downloadgentoo-4d77d73ec96a181ce2a2441f299e3f6ab0d20ccd.tar.gz
gentoo-4d77d73ec96a181ce2a2441f299e3f6ab0d20ccd.tar.bz2
gentoo-4d77d73ec96a181ce2a2441f299e3f6ab0d20ccd.zip
dev-lang/hy: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/hy/hy-0.12.0.ebuild')
-rw-r--r--dev-lang/hy/hy-0.12.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-lang/hy/hy-0.12.0.ebuild b/dev-lang/hy/hy-0.12.0.ebuild
deleted file mode 100644
index e03e52c7f871..000000000000
--- a/dev-lang/hy/hy-0.12.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python{2_7,3_5})
-
-inherit distutils-r1 eutils
-DESCRIPTION="A LISP dialect running in python"
-HOMEPAGE="http://hylang.org/"
-SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="test doc examples"
-
-RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
- >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/astor-0.5[${PYTHON_USEDEP}]
- dev-python/clint[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/tox[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )"
-src_prepare() {
- use examples && EXAMPLES=( eg/. )
- use doc && HTML_DOCS=( docs/_build/html/. )
-}
-
-python_compile_all() {
- use doc && emake docs
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}