summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-10 16:23:15 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:44:59 +0100
commit8032fc02539ad46cdab630488595470d2f565b06 (patch)
tree493d8c019bea7132af12f63cef5a6d8c3037e73a /dev-lang/hy/hy-0.15.0.ebuild
parentdev-libs/nanomsg: bump to v1.1.5 (diff)
downloadgentoo-8032fc02539ad46cdab630488595470d2f565b06.tar.gz
gentoo-8032fc02539ad46cdab630488595470d2f565b06.tar.bz2
gentoo-8032fc02539ad46cdab630488595470d2f565b06.zip
dev-lang/hy: bump to v0.15.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/hy/hy-0.15.0.ebuild')
-rw-r--r--dev-lang/hy/hy-0.15.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lang/hy/hy-0.15.0.ebuild b/dev-lang/hy/hy-0.15.0.ebuild
new file mode 100644
index 000000000000..ad923928b2f8
--- /dev/null
+++ b/dev-lang/hy/hy-0.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python{2_7,3_5,3_6})
+
+inherit distutils-r1 eutils
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/astor-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/clint-0.4[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/funcparserlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.0-do-not-install-get_version.py.patch )
+
+src_prepare() {
+ default
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests -vv || die "Tests failed under ${EPYTHON}"
+}