summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-04-26 13:51:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-04-26 13:51:32 +0000
commit22b14cbb06d2144be556693a9099eb0fcc9f5390 (patch)
tree0927fab057af0fed643187dc27dfc8f34e7f47ed /dev-lang/hy
parentsci-geosciences/gpxsee: remove old (diff)
downloadgentoo-22b14cbb06d2144be556693a9099eb0fcc9f5390.tar.gz
gentoo-22b14cbb06d2144be556693a9099eb0fcc9f5390.tar.bz2
gentoo-22b14cbb06d2144be556693a9099eb0fcc9f5390.zip
dev-lang/hy: Bump to 0.20.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-lang/hy')
-rw-r--r--dev-lang/hy/Manifest1
-rw-r--r--dev-lang/hy/hy-0.20.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-lang/hy/Manifest b/dev-lang/hy/Manifest
index 2af3a5fb0af3..d007b9c53fff 100644
--- a/dev-lang/hy/Manifest
+++ b/dev-lang/hy/Manifest
@@ -1 +1,2 @@
DIST hy-0.17.0.tar.gz 438729 BLAKE2B f699198a3181592dc0a1c12ecb85defce5ee592eb3c949635f37af36f39f452b081b18b46a122d515a7246d448c1710eedd8015a14f18dc074c61f0cfccecf8f SHA512 18601bf47df2120f8833a1ae211c416dc90825f31cd50b259adfe0585089a623d0fea13512b2935b093e14d8595c93bc1610939d5f1d664f6acf7ddf7e341542
+DIST hy-0.20.0.tar.gz 448041 BLAKE2B b728d5894403bc40e899979153ec7a0a0479a82ab5dd85699d87df150cf9169d199c06897a9573f9087623ae43a594536e56779bb6db463fd6490d944e6743c4 SHA512 ccad5f3704c48136ce77278c0bc470bf0dfbd56d8f81cfab22d90517d915cf22a6e1a976aecbb17fc9a7260fde23f3feff4572b8af80d10ceed767aef301af86
diff --git a/dev-lang/hy/hy-0.20.0.ebuild b/dev-lang/hy/hy-0.20.0.ebuild
new file mode 100644
index 000000000000..d89f01291305
--- /dev/null
+++ b/dev-lang/hy/hy-0.20.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python3_7 python3_8 python3_9)
+
+inherit distutils-r1
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/astor-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/clint-0.4[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/funcparserlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.0-do-not-install-get_version.py.patch )
+
+src_prepare() {
+ default
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests -vv || die "Tests failed under ${EPYTHON}"
+}