summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/io/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/io/files')
-rw-r--r--dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch160
1 files changed, 160 insertions, 0 deletions
diff --git a/dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch b/dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch
new file mode 100644
index 000000000000..ff2e91152708
--- /dev/null
+++ b/dev-lang/io/files/io-2011.09.12-gentoo-fixes.patch
@@ -0,0 +1,160 @@
+diff -Nurwp io-2011.09.12-orig/addons/CMakeLists.txt io-2011.09.12-chag/addons/CMakeLists.txt
+--- io-2011.09.12-orig/addons/CMakeLists.txt 2011-09-12 18:14:12.000000000 -0400
++++ io-2011.09.12-chag/addons/CMakeLists.txt 2012-04-29 08:16:56.000000000 -0400
+@@ -52,71 +52,135 @@ add_subdirectory(BigNum)
+ add_subdirectory(Bitly)
+ add_subdirectory(Blowfish)
+ add_subdirectory(Box)
++if(ENABLE_CFFI)
+ add_subdirectory(CFFI)
++endif(ENABLE_CFFI)
++if(ENABLE_CGI)
+ add_subdirectory(CGI)
++endif(ENABLE_CGI)
+ #add_subdirectory(Cairo) # XXX: Broken on OSX: ld: library not found for -lpng12
++if(ENABLE_CLUTTER)
+ add_subdirectory(Clutter)
++endif(ENABLE_CLUTTER)
+ add_subdirectory(ContinuedFraction)
++if(ENABLE_CURSES)
+ add_subdirectory(Curses)
++endif(ENABLE_CURSES)
++if(ENABLE_DBI)
+ add_subdirectory(DBI)
++endif(ENABLE_DBI)
+ add_subdirectory(DistributedObjects)
++if(ENABLE_EDITLINE)
+ add_subdirectory(EditLine)
++endif(ENABLE_EDITLINE)
+ add_subdirectory(Facebook)
++if(ENABLE_FLUX)
+ add_subdirectory(Flux)
++endif(ENABLE_FLUX)
+ add_subdirectory(Fnmatch)
++if(ENABLE_FONT)
+ add_subdirectory(Font)
++endif(ENABLE_FONT)
+ add_subdirectory(GLFW) # XXX: Can't meet dependencies
++if(ENABLE_GOOGLESEARCH)
+ add_subdirectory(GoogleSearch)
++endif(ENABLE_GOOGLESEARCH)
++if(ENABLE_HTTPCLIENT)
+ add_subdirectory(HttpClient)
++endif(ENABLE_HTTPCLIENT)
++if(ENABLE_IMAGE)
+ add_subdirectory(Image)
++endif(ENABLE_IMAGE)
++if(ENABLE_LZO)
+ add_subdirectory(LZO)
++endif(ENABLE_LZO)
++if(ENABLE_LIBSNDFILE)
+ add_subdirectory(LibSndFile)
++endif(ENABLE_LIBSNDFILE)
++if(ENABLE_LIBXML2)
+ add_subdirectory(Libxml2)
++endif(ENABLE_LIBXML2)
+ add_subdirectory(Loki)
++if(ENABLE_LOUDMOUTH)
+ add_subdirectory(Loudmouth)
++endif(ENABLE_LOUDMOUTH)
++if(ENABLE_MD5SUM)
+ add_subdirectory(MD5)
++endif(ENABLE_MD5SUM)
+ add_subdirectory(Memcached)
++if(ENABLE_MYSQL)
+ add_subdirectory(MySQL)
++endif(ENABLE_MYSQL)
+ #add_subdirectory(NetworkAdapter)
+ add_subdirectory(NotificationCenter)
+ #add_subdirectory(Oauth) # OAuth should no longer break CMake configuration on Windows now.
+ #add_subdirectory(ODE) # XXX: Can't meet dependencies
+ add_subdirectory(ObjcBridge) # XXX: Broken for me -- Objective-C 2.0 not supported
+ add_subdirectory(Obsidian)
++if(ENABLE_OGG)
+ add_subdirectory(Ogg)
++endif(ENABLE_OGG)
++if(ENABLE_OPENGL)
+ add_subdirectory(OpenGL)
++endif(ENABLE_OPENGL)
+ #add_subdirectory(PortAudio) # XXX: Dependency broken for me
++if(ENABLE_POSTGRESQL)
+ add_subdirectory(PostgreSQL)
++endif(ENABLE_POSTGRESQL)
+ #add_subdirectory(Postgres)
++if(ENABLE_PYTHON)
+ add_subdirectory(Python)
++endif(ENABLE_PYTHON)
+ add_subdirectory(QDBM)
+ add_subdirectory(Random)
+ add_subdirectory(Range)
+ add_subdirectory(Rational)
++if(ENABLE_READLINE)
+ add_subdirectory(ReadLine)
++endif(ENABLE_READLINE)
++if(ENABLE_REGEX)
+ add_subdirectory(Regex)
++endif(ENABLE_REGEX)
+ add_subdirectory(SGML)
++if(ENABLE_SHA1)
+ add_subdirectory(SHA1)
++endif(ENABLE_SHA1)
+ #add_subdirectory(SQLite) # XXX: Want to delete in favour of SQLite3
++if(ENABLE_SQLITE3)
+ add_subdirectory(SQLite3)
++endif(ENABLE_SQLITE3)
+ #add_subdirectory(SampleRateConverter)
+ add_subdirectory(SecureSocket)
+ #add_subdirectory(SkipDB) # XXX: Disabled...why?
++if(ENABLE_SOCKET)
+ add_subdirectory(Socket)
++endif(ENABLE_SOCKET)
+ #add_subdirectory(SoundTouch) # XXX: I can't meet dependencies
+ add_subdirectory(SqlDatabase)
++if(ENABLE_SYSLOG)
+ add_subdirectory(Syslog)
++endif(ENABLE_SYSLOG)
+ add_subdirectory(SystemCall)
+ #add_subdirectory(TagDB) # XXX: I can't meet dependencies
+ #add_subdirectory(TagLib)
++if(ENABLE_THEORA)
+ add_subdirectory(Theora)
++endif(ENABLE_THEORA)
++if(ENABLE_THREAD)
+ add_subdirectory(Thread)
++endif(ENABLE_THREAD)
+ add_subdirectory(TokyoCabinet)
++if(ENABLE_TWITTER)
+ add_subdirectory(Twitter)
++endif(ENABLE_TWITTER)
+ add_subdirectory(UUID)
+ add_subdirectory(User)
+ add_subdirectory(VertexDB)
+ add_subdirectory(Volcano)
++if(ENABLE_VORBIS)
+ add_subdirectory(Vorbis)
++endif(ENABLE_VORBIS)
+ add_subdirectory(Yajl)
++if(ENABLE_ZLIB)
+ add_subdirectory(Zlib)
++endif(ENABLE_ZLIB)
+diff -Nurwp io-2011.09.12-orig/libs/basekit/CMakeLists.txt io-2011.09.12-chag/libs/basekit/CMakeLists.txt
+--- io-2011.09.12-orig/libs/basekit/CMakeLists.txt 2011-09-12 18:14:12.000000000 -0400
++++ io-2011.09.12-chag/libs/basekit/CMakeLists.txt 2012-04-21 22:06:47.000000000 -0400
+@@ -24,3 +24,6 @@ add_library(basekit SHARED ${SRCS})
+ # The following add the install target, so we put libbasekit.* in our
+ # install prefix.
+ install(TARGETS basekit DESTINATION lib)
++
++# Link basekit library against libdl (required by as-needed linking).
++target_link_libraries(basekit dl)
+diff -Nurwp io-2011.09.12-orig/libs/coroutine/source/asm.S io-2011.09.12-chag/libs/coroutine/source/asm.S
+--- io-2011.09.12-orig/libs/coroutine/source/asm.S 2011-09-12 18:14:12.000000000 -0400
++++ io-2011.09.12-chag/libs/coroutine/source/asm.S 2012-04-21 23:20:26.000000000 -0400
+@@ -258,3 +258,7 @@ SET:
+ ldr r0, [r0]
+ mov pc, lr
+ #endif
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif