summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-25 07:34:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-25 07:35:04 +0000
commit4615e51deb239a6e860ada83fc962900a956ed56 (patch)
treeacdfa28591b712194f7abd6d4a3812fbc9e38655 /dev-lang/julia
parentkde-misc/openofficeorg-thumbnail: Drop slot 4 (diff)
downloadgentoo-4615e51deb239a6e860ada83fc962900a956ed56.tar.gz
gentoo-4615e51deb239a6e860ada83fc962900a956ed56.tar.bz2
gentoo-4615e51deb239a6e860ada83fc962900a956ed56.zip
dev-lang/julia: Disable doc fetching #628358
This is a dirty hack and most likely not a good solution. Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/julia-0.6.0-r1.ebuild (renamed from dev-lang/julia/julia-0.6.0.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/julia/julia-0.6.0.ebuild b/dev-lang/julia/julia-0.6.0-r1.ebuild
index f3f54493445c..9c6d3d76eb33 100644
--- a/dev-lang/julia/julia-0.6.0.ebuild
+++ b/dev-lang/julia/julia-0.6.0-r1.ebuild
@@ -102,6 +102,9 @@ src_prepare() {
sed -i \
-e "s|ar -rcs|$(tc-getAR) -rcs|g" \
src/Makefile || die
+
+ # disable doc install starting git fetching
+ sed -i -e 's~install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html~install: $(build_depsbindir)/stringreplace~' Makefile || die
}
src_configure() {
@@ -159,7 +162,10 @@ src_install() {
# Julia is special. It tries to find a valid git repository (that would
# normally be cloned during compilation/installation). Just make it
# happy...
- git init && git commit -a --allow-empty -m "initial" || die "git failed"
+ git init && \
+ git config --local user.email "whatyoudoing@example.com" && \
+ git config --local user.name "Whyyyyyy" && \
+ git commit -a --allow-empty -m "initial" || die "git failed"
emake install \
prefix="/usr" DESTDIR="${D}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"