summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2020-08-13 19:01:11 -0400
committerMatthias Maier <tamiko@gentoo.org>2020-10-02 12:41:23 -0500
commitf894b91a6a93535ed2e1479d2ccc7a4abe773dd0 (patch)
treec916e0fcda0297ff104f9f148807c0f5c1f7d83e /dev-lang/julia
parentlibvirt: Version updated to 6.8.0. (diff)
downloadgentoo-f894b91a6a93535ed2e1479d2ccc7a4abe773dd0.tar.gz
gentoo-f894b91a6a93535ed2e1479d2ccc7a4abe773dd0.tar.bz2
gentoo-f894b91a6a93535ed2e1479d2ccc7a4abe773dd0.zip
dev-lang/julia: make sci-visualization/gr optional
This avoids pulling in around 70 dependencies on a clean install, the bulk of them being X libraries. Closes: https://github.com/gentoo/gentoo/pull/17149 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/julia-1.4.0-r2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/julia/julia-1.4.0-r2.ebuild b/dev-lang/julia/julia-1.4.0-r2.ebuild
index 0755009420f0..6529f36eb263 100644
--- a/dev-lang/julia/julia-1.4.0-r2.ebuild
+++ b/dev-lang/julia/julia-1.4.0-r2.ebuild
@@ -59,7 +59,6 @@ RDEPEND+="
sci-libs/spqr:0=
sci-libs/umfpack:0=
sci-mathematics/glpk:0=
- >=sci-visualization/gr-0.50.0-r1
>=sys-libs/libunwind-1.1:0=
sys-libs/readline:0=
sys-libs/zlib:0=
@@ -202,3 +201,7 @@ src_install() {
mv "${ED}"/usr/share/doc/julia/html "${ED}"/usr/share/doc/${PF} || die
rmdir "${ED}"/usr/share/doc/julia || die
}
+
+pkg_postinst() {
+ elog "To use Plots, you will need to install sci-visualization/gr."
+}