summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 18:43:32 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:22:32 +0000
commitc9b5c10cc8dceeb1053ea6309098d5961df4b70b (patch)
treeefdd9c2d4963f2e902f06d5394e9d9da5a9f165d /dev-lang/mlton
parentdev-lang/mlton: drop 20130715 (diff)
downloadgentoo-c9b5c10cc8dceeb1053ea6309098d5961df4b70b.tar.gz
gentoo-c9b5c10cc8dceeb1053ea6309098d5961df4b70b.tar.bz2
gentoo-c9b5c10cc8dceeb1053ea6309098d5961df4b70b.zip
dev-lang/mlton: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/mlton')
-rw-r--r--dev-lang/mlton/mlton-20180207.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-lang/mlton/mlton-20180207.ebuild b/dev-lang/mlton/mlton-20180207.ebuild
index dc132ad34edc..f55bb40d5a14 100644
--- a/dev-lang/mlton/mlton-20180207.ebuild
+++ b/dev-lang/mlton/mlton-20180207.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit check-reqs eutils multibuild pax-utils
+inherit check-reqs multibuild pax-utils
DESCRIPTION="Standard ML optimizing compiler and libraries"
BASE_URI="mirror://sourceforge/${PN}"
@@ -147,12 +147,15 @@ mlton_create_bin_stubs() {
src_prepare() {
if ! use binary; then
# For Gentoo hardened: paxmark the mlton-compiler, mllex and mlyacc executables
- epatch "${FILESDIR}/${PN}-20180207-paxmark.patch"
+ eapply "${FILESDIR}/${PN}-20180207-paxmark.patch"
# Fix the bootstrap-smlnj and bootstrap-polyml Makefile targets
- epatch "${FILESDIR}/${PN}-20180207-bootstrap.patch"
+ eapply "${FILESDIR}/${PN}-20180207-bootstrap.patch"
fi
+
default
+
$(mlton_create_bin_stubs)
+
if use binary; then
pax-mark m "${R}/lib/${PN}/mlton-compile"
pax-mark m "${R}/bin/mllex"