summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/mono/mono-3.12.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/mono/mono-3.12.1.ebuild')
-rw-r--r--dev-lang/mono/mono-3.12.1.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/dev-lang/mono/mono-3.12.1.ebuild b/dev-lang/mono/mono-3.12.1.ebuild
new file mode 100644
index 000000000000..03928d106f7d
--- /dev/null
+++ b/dev-lang/mono/mono-3.12.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+
+inherit eutils linux-info mono-env flag-o-matic pax-utils autotools-utils
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE="nls minimal pax_kernel xen doc debug"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+"
+
+pkg_pretend() {
+ # If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
+ # See http://bugs.gentoo.org/261869 for more info."
+ CONFIG_CHECK="~SYSVIPC"
+ use kernel_linux && check_extra_config
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTEC is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ # Remove this at your own peril. Mono will barf in unexpected ways.
+ append-flags -fno-strict-aliasing
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # NOTE: We need the static libs for now so mono-debugger works.
+ # See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
+ #
+ # --without-moonlight since www-plugins/moonlight is not the only one
+ # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
+ #
+ # --with-profile4 needs to be always enabled since it's used by default
+ # and, otherwise, problems like bug #340641 appear.
+ #
+ # sgen fails on ppc, bug #359515
+ local myeconfargs=(
+ --enable-system-aot=yes
+ --enable-static
+ --disable-quiet-build
+ --without-moonlight
+ --with-libgdiplus=$(usex minimal no installed)
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --with-jit
+ --disable-dtrace
+ --with-profile4
+ --with-sgen=$(usex ppc no yes)
+ $(use_with doc mcs-docs)
+ $(use_enable debug)
+ $(use_enable nls)
+ )
+
+ autotools-utils_src_configure
+
+ # FIX for uncompilable 3.4.0 sources
+ FF="${WORKDIR}/mono-3.4.0/mcs/tools/xbuild/targets/Microsoft.Portable.Common.targets"
+ rm -f $FF
+ touch $FF
+ echo '<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">' >> $FF
+ echo ' <Import Project="..\\Microsoft.Portable.Core.props" />' >> $FF
+ echo ' <Import Project="..\\Microsoft.Portable.Core.targets" />' >> $FF
+ echo '</Project>' >> $FF
+}
+
+src_compile() {
+ nonfatal autotools-utils_src_compile || {
+ eqawarn "maintainer of this ebuild has no idea why it fails. If you happen to know how to fix it - please let me know"
+ autotools-utils_src_compile
+ }
+}
+
+src_test() {
+ cd mcs/tests || die
+ emake check
+}