summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-27 00:31:48 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-27 00:32:22 +0100
commit7617f03216587b94eec6c655202d27efdef238f4 (patch)
tree7822b9880164257d6022711057a8f1a5b656b2e3 /dev-lang/nim/nim-0.19.0.ebuild
parentsys-block/storcli: amd64 & x86 stable (diff)
downloadgentoo-7617f03216587b94eec6c655202d27efdef238f4.tar.gz
gentoo-7617f03216587b94eec6c655202d27efdef238f4.tar.bz2
gentoo-7617f03216587b94eec6c655202d27efdef238f4.zip
dev-lang/nim: bump up to 0.19.0, bug #635032
While at it move installation to /usr/ prefix. Reported-by: Jonas Stein Closes: https://bugs.gentoo.org/635032 Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-lang/nim/nim-0.19.0.ebuild')
-rw-r--r--dev-lang/nim/nim-0.19.0.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-lang/nim/nim-0.19.0.ebuild b/dev-lang/nim/nim-0.19.0.ebuild
new file mode 100644
index 000000000000..c86fab3680ee
--- /dev/null
+++ b/dev-lang/nim/nim-0.19.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 multiprocessing
+
+DESCRIPTION="compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +readline test"
+
+RESTRICT=test # need to sort out depends and numerous failures
+
+RDEPEND="
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${DEPEND}
+ test? ( net-libs/nodejs )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-paths.patch
+)
+
+_run() {
+ echo "$@"
+ "$@" || die "'$*' failed"
+}
+
+nim_use_enable() {
+ [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
+ use $1 && echo "-d:$2"
+}
+
+src_compile() {
+ _run ./build.sh
+
+ _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
+ _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
+ # build nimble and friends
+ # --stable to avoid pulling HEAD nimble
+ PATH="./bin:$PATH" _run ./koch --stable tools
+
+ if use doc; then
+ PATH="./bin:$PATH" _run ./koch web
+ fi
+}
+
+src_test() {
+ PATH="./bin:$PATH" _run ./koch test
+}
+
+src_install() {
+ PATH="./bin:$PATH" _run ./koch install "${ED%/}"
+ rm -r "${ED%/}/usr/share/nim/doc" || die "failed to remove 'doc'"
+
+ exeinto /usr/bin
+
+ local bin_exe
+ for bin_exe in bin/*; do
+ # './koch install' installs only 'nim' binary
+ # but not the rest
+ [[ ${bin_exe} == bin/nim ]] && continue
+ doexe "${bin_exe}"
+ done
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ dodoc doc/*.html
+ fi
+
+ newbashcomp tools/nim.bash-completion ${PN}
+}