summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-05-14 08:31:00 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-05-14 08:31:00 +0100
commit7b85ece2e450cc892d913ea639cc254c861ab09a (patch)
treeeab44549e0c8b41e6c7d1827e95aff3b69c2a0cf /dev-lang/nim/nim-0.19.6.ebuild
parentdev-util/radare2: drop old (diff)
downloadgentoo-7b85ece2e450cc892d913ea639cc254c861ab09a.tar.gz
gentoo-7b85ece2e450cc892d913ea639cc254c861ab09a.tar.bz2
gentoo-7b85ece2e450cc892d913ea639cc254c861ab09a.zip
dev-lang/nim: bump up to 0.19.6
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/nim/nim-0.19.6.ebuild')
-rw-r--r--dev-lang/nim/nim-0.19.6.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-lang/nim/nim-0.19.6.ebuild b/dev-lang/nim/nim-0.19.6.ebuild
new file mode 100644
index 000000000000..2dc958a2a86b
--- /dev/null
+++ b/dev-lang/nim/nim-0.19.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 multiprocessing
+
+DESCRIPTION="compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +readline test"
+
+RESTRICT=test # need to sort out depends and numerous failures
+
+RDEPEND="
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${DEPEND}
+ test? ( net-libs/nodejs )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.0-paths.patch
+)
+
+_run() {
+ echo "$@"
+ "$@" || die "'$*' failed"
+}
+
+nim_use_enable() {
+ [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
+ use $1 && echo "-d:$2"
+}
+
+src_compile() {
+ export XDG_CACHE_HOME=${T}/cache #667182
+
+ _run ./build.sh
+
+ _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
+ _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
+ # build nimble and friends
+ # --stable to avoid pulling HEAD nimble
+ PATH="./bin:$PATH" _run ./koch --stable tools
+
+ if use doc; then
+ PATH="./bin:$PATH" _run ./koch doc
+ fi
+}
+
+src_test() {
+ PATH="./bin:$PATH" _run ./koch test
+}
+
+src_install() {
+ PATH="./bin:$PATH" _run ./koch install "${ED%/}"
+ rm -r "${ED%/}/usr/share/nim/doc" || die "failed to remove 'doc'"
+
+ exeinto /usr/bin
+
+ local bin_exe
+ for bin_exe in bin/*; do
+ # './koch install' installs only 'nim' binary
+ # but not the rest
+ [[ ${bin_exe} == bin/nim ]] && continue
+ doexe "${bin_exe}"
+ done
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ dodoc doc/html/*.html
+ fi
+
+ newbashcomp tools/nim.bash-completion ${PN}
+}