summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-08-07 23:02:53 +1200
committerKent Fredric <kentnl@gentoo.org>2019-08-07 23:41:52 +1200
commit7129beca04606b3ad27857e64e04184093158d4e (patch)
tree581d3b802131feef8dc4df8952443a83ecbf97bb /dev-lang/nqp
parentdev-lang/nqp: Employ ${EPREFIX} in --prefix (diff)
downloadgentoo-7129beca04606b3ad27857e64e04184093158d4e.tar.gz
gentoo-7129beca04606b3ad27857e64e04184093158d4e.tar.bz2
gentoo-7129beca04606b3ad27857e64e04184093158d4e.zip
dev-lang/nqp: Convert live ebuild to EAPI7
Note that this ebuild currently is unusable as: 1. Using moar w/ moar-9999 currently has an odd problem where it needs to use a non-existent "ffi.h" 2. Using jvm currently is unsupportable as upstream currently requires jdk-1.9/9, which we presently don't have any support for in Gentoo. Hopefully these issues won't be present when I use this ebuild as a base for the most recently shipped nqp release. See also: https://github.com/perl6/nqp/issues/571 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-lang/nqp')
-rw-r--r--dev-lang/nqp/nqp-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/nqp/nqp-9999.ebuild b/dev-lang/nqp/nqp-9999.ebuild
index e62293edbfb3..120648d125d4 100644
--- a/dev-lang/nqp/nqp-9999.ebuild
+++ b/dev-lang/nqp/nqp-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit java-pkg-opt-2 multibuild
@@ -30,7 +30,8 @@ CDEPEND="java? (
moar? ( ~dev-lang/moarvm-${PV}[clang=] )"
RDEPEND="${CDEPEND}
java? ( >=virtual/jre-1.8 )"
-DEPEND="${CDEPEND}
+DEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
clang? ( sys-devel/clang )
java? ( >=virtual/jdk-1.8 )
dev-lang/perl"