summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:18:07 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:18:07 +0100
commit22761029fffcbb54ae177dcfef74ced08f3ae980 (patch)
tree8e51c86f38507ed400dff869cf9df10fc2fe2da5 /dev-lang/open-cobol/open-cobol-1.1.ebuild
parentdev-games/libnw: disable static libs (diff)
downloadgentoo-22761029fffcbb54ae177dcfef74ced08f3ae980.tar.gz
gentoo-22761029fffcbb54ae177dcfef74ced08f3ae980.tar.bz2
gentoo-22761029fffcbb54ae177dcfef74ced08f3ae980.zip
dev-lang/open-cobol: disable static libs
Closes: https://bugs.gentoo.org/726916 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/open-cobol/open-cobol-1.1.ebuild')
-rw-r--r--dev-lang/open-cobol/open-cobol-1.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/open-cobol/open-cobol-1.1.ebuild b/dev-lang/open-cobol/open-cobol-1.1.ebuild
index 83ba13532f67..d7fd39c417a0 100644
--- a/dev-lang/open-cobol/open-cobol-1.1.ebuild
+++ b/dev-lang/open-cobol/open-cobol-1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,6 +29,11 @@ src_configure() {
econf \
$(use_with berkdb db) \
$(use_enable nls) \
- $(use_with readline)
+ $(use_with readline) \
+ --disable-static
+}
+
+src_install() {
default
+ find "${ED}" -name '*.la' -delete || die
}