summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-lang/opendylan/opendylan-2013.1-r1.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/opendylan/opendylan-2013.1-r1.ebuild')
-rw-r--r--dev-lang/opendylan/opendylan-2013.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/opendylan/opendylan-2013.1-r1.ebuild b/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
index a5a3a00fc97d..78ee3789828b 100644
--- a/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
+++ b/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
@@ -71,9 +71,9 @@ src_configure() {
PATH=/opt/opendylan/bin:$PATH
fi
if use amd64; then
- econf --prefix=/opt/opendylan || die
+ econf --prefix=/opt/opendylan
else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
+ econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
fi
if use x86; then
# Includedir, pointing at something wrong
@@ -87,7 +87,7 @@ src_configure() {
src_compile() {
ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap || die
+ emake -j1 3-stage-bootstrap
}
src_install() {