summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-02-20 11:48:40 +0200
committerMart Raudsepp <leio@gentoo.org>2021-02-20 12:12:13 +0200
commit75ad69a7792753f1525041158b5dcf3889ad2832 (patch)
tree54d08c7e5681236a55a338ea464fd0967683cb61 /dev-lang/orc
parentmedia-libs/gst-rtsp-server: remove old (diff)
downloadgentoo-75ad69a7792753f1525041158b5dcf3889ad2832.tar.gz
gentoo-75ad69a7792753f1525041158b5dcf3889ad2832.tar.bz2
gentoo-75ad69a7792753f1525041158b5dcf3889ad2832.zip
dev-lang/orc: remove old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-lang/orc')
-rw-r--r--dev-lang/orc/Manifest2
-rw-r--r--dev-lang/orc/files/0.4.29-test-rounding.patch73
-rw-r--r--dev-lang/orc/metadata.xml3
-rw-r--r--dev-lang/orc/orc-0.4.28-r1.ebuild75
-rw-r--r--dev-lang/orc/orc-0.4.29.ebuild81
5 files changed, 0 insertions, 234 deletions
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
index 8df1a57c6ab0..a0ffc682c76e 100644
--- a/dev-lang/orc/Manifest
+++ b/dev-lang/orc/Manifest
@@ -1,3 +1 @@
-DIST orc-0.4.28.tar.xz 469460 BLAKE2B 86fa2d10a33fbffbb2b96827adbddaa81d0baa8135fe21fba338cbcd25a1c1e853873ec1c4ef5c0a32d66ba95f855f1f16ddbc32f68a89e5a98c75b9b0261aa7 SHA512 2ae3100e7d0c03eba9a8a10a8924da4d729e1967b63e5dfdf88c4aee907d7ece82c782d74f4cb7e28a366dd74ce5e1ddc6e2b971e5a2f879b0501cc313b93410
-DIST orc-0.4.29.tar.xz 465076 BLAKE2B f7c81429d95af7031f190a4c3d52959eda1835d3092493e3fa15e4b6719290c1c1f23459448f7c499ba4085ad8d7b9f49e687521d76823a1e8ce6d3916b39a37 SHA512 57aa75bbefa9ba9ffcce97affd504c13c57612e2409863c011555bed6ff6ba224d38ed66b715bf103679a8ee28ddae427db3d78c7b4a2ddfa7dbd72a4fa81726
DIST orc-0.4.31.tar.xz 177768 BLAKE2B f06fd6be70063ebc82b45c1801a53aab66b5fc8a85c33991602488ec8ed29f2271df20c3780655953cabe33e865530b1218aafa0592261bcc5dccc4a4b3945e7 SHA512 4e97597e70982dbfc239d1ef9a8913b0155e5aaac15d91162d7f73a1095bd944e27fbe6d6194b9f74af07b985a44b1d9dddbe917425e1ad9e8da17ce86495696
diff --git a/dev-lang/orc/files/0.4.29-test-rounding.patch b/dev-lang/orc/files/0.4.29-test-rounding.patch
deleted file mode 100644
index 653132fcb8e0..000000000000
--- a/dev-lang/orc/files/0.4.29-test-rounding.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 73986d82e1ae60b224b401143cd4ce2c452bf326 Mon Sep 17 00:00:00 2001
-From: Doug Nazar <nazard@nazar.ca>
-Date: Wed, 7 Aug 2019 00:11:35 -0400
-Subject: [PATCH] orctest: Switch nearby float comparison to ULP method
-
----
- orc-test/orcarray.c | 7 ++-----
- orc-test/orctest.c | 8 ++++----
- 2 files changed, 6 insertions(+), 9 deletions(-)
-
-diff --git a/orc-test/orcarray.c b/orc-test/orcarray.c
-index c0666c5..b27a1f9 100644
---- a/orc-test/orcarray.c
-+++ b/orc-test/orcarray.c
-@@ -211,9 +211,6 @@ orc_array_set_pattern_2 (OrcArray *array, OrcRandomContext *context,
- }
- }
-
--#define MIN_NONDENORMAL (1.1754944909521339405e-38)
--#define MIN_NONDENORMAL_D (2.2250738585072014e-308)
--
- int
- orc_array_compare (OrcArray *array1, OrcArray *array2, int flags)
- {
-@@ -230,7 +227,7 @@ orc_array_compare (OrcArray *array1, OrcArray *array2, int flags)
- for (i=0;i<array1->n;i++){
- if (isnan(a[i]) && isnan(b[i])) continue;
- if (a[i] == b[i]) continue;
-- if (fabs(a[i] - b[i]) < MIN_NONDENORMAL) continue;
-+ if ((a[i] < 0.0) == (b[i] < 0.0) && abs(*(orc_uint32 *)&a[i] - *(orc_uint32 *)&b[i]) <= 2) continue;
- return FALSE;
- }
- }
-@@ -247,7 +244,7 @@ orc_array_compare (OrcArray *array1, OrcArray *array2, int flags)
- for (i=0;i<array1->n;i++){
- if (isnan(a[i]) && isnan(b[i])) continue;
- if (a[i] == b[i]) continue;
-- if (fabs(a[i] - b[i]) < MIN_NONDENORMAL_D) continue;
-+ if ((a[i] < 0.0) == (b[i] < 0.0) && abs(*(orc_uint64 *)&a[i] - *(orc_uint64 *)&b[i]) <= 2) continue;
- return FALSE;
- }
- }
-diff --git a/orc-test/orctest.c b/orc-test/orctest.c
-index 9f0e942..54658bc 100644
---- a/orc-test/orctest.c
-+++ b/orc-test/orctest.c
-@@ -44,8 +44,6 @@
- #define snprintf _snprintf
- #endif
-
--#define MIN_NONDENORMAL (1.1754944909521339405e-38)
--
- void _orc_profile_init(void);
-
- OrcRandomContext rand_context;
-@@ -527,10 +525,12 @@ float_compare (OrcArray *array1, OrcArray *array2, int i, int j)
- case 4:
- if (isnan(*(float *)ptr1) && isnan(*(float *)ptr2)) return TRUE;
- if (*(float *)ptr1 == *(float *)ptr2) return TRUE;
-- if (fabs(*(float *)ptr1 - *(float *)ptr2) < MIN_NONDENORMAL) return TRUE;
-+ if ((*(float *)ptr1 < 0.0) == (*(float *)ptr2 < 0.0) && abs(*(orc_uint32 *)ptr1 - *(orc_uint32 *)ptr2) <= 2) return TRUE;
- return FALSE;
- case 8:
-- /* FIXME */
-+ if (isnan(*(double *)ptr1) && isnan(*(double *)ptr2)) return TRUE;
-+ if (*(double *)ptr1 == *(double *)ptr2) return TRUE;
-+ if ((*(double *)ptr1 < 0.0) == (*(double *)ptr2 < 0.0) && abs(*(orc_uint64 *)ptr1 - *(orc_uint64 *)ptr2) <= 2) return TRUE;
- return FALSE;
- }
- return FALSE;
---
-2.21.0
-
diff --git a/dev-lang/orc/metadata.xml b/dev-lang/orc/metadata.xml
index 2ac858de72bb..42656fdfde29 100644
--- a/dev-lang/orc/metadata.xml
+++ b/dev-lang/orc/metadata.xml
@@ -5,7 +5,4 @@
<email>gstreamer@gentoo.org</email>
<name>GStreamer package maintainers</name>
</maintainer>
-<use>
- <flag name="pax_kernel">Apply patch needed for pax enabled kernels.</flag>
-</use>
</pkgmetadata>
diff --git a/dev-lang/orc/orc-0.4.28-r1.ebuild b/dev-lang/orc/orc-0.4.28-r1.ebuild
deleted file mode 100644
index 1d22e3f53076..000000000000
--- a/dev-lang/orc/orc-0.4.28-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic ltprune multilib-minimal pax-utils
-
-DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="BSD BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples pax_kernel static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- >=dev-util/gtk-doc-am-1.12
-"
-
-DOCS=( README RELEASE )
-
-src_prepare() {
- default
-
- # Do not build examples
- sed -e '/SUBDIRS/ s:examples::' \
- -i Makefile.am Makefile.in || die
-}
-
-multilib_src_configure() {
- # any optimisation on PPC/Darwin yields in a complaint from the assembler
- # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
- # the same for Intel/Darwin, although the error message there is different
- # but along the same lines
- [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
-
- # FIXME: handle backends per arch? What about cross-compiling for the other arches?
- ECONF_SOURCE="${S}" econf \
- --disable-gtk-doc \
- --enable-backend=all \
- $(use_enable static-libs static)
- # TODO: bug #645232 - Not ready for this yet, as it installs some headers to live and gst-plugins-base:0.10 includes some
- # Additionally it doesn't seem good that FEATURES=test would change what files are installed (headers + orctest.so + orc-bugreport)
- # $(use_enable test tests)
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files --all
-
- if use pax_kernel; then
- pax-mark m "${ED}"usr/bin/orc-bugreport
- pax-mark m "${ED}"usr/bin/orcc
- pax-mark m "${ED}"usr/$(get_libdir)/liborc*.so*
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.c,*.orc}
- fi
-}
-
-pkg_postinst() {
- if use pax_kernel; then
- ewarn "Please run \"revdep-pax\" after installation".
- ewarn "It's provided by sys-apps/elfix."
- fi
-}
diff --git a/dev-lang/orc/orc-0.4.29.ebuild b/dev-lang/orc/orc-0.4.29.ebuild
deleted file mode 100644
index 11728d5cf617..000000000000
--- a/dev-lang/orc/orc-0.4.29.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic ltprune multilib-minimal pax-utils
-
-DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="BSD BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples pax_kernel static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- >=dev-util/gtk-doc-am-1.12
-"
-
-DOCS=( README RELEASE )
-
-PATCHES=(
- # Fixes some tests on various platforms (AMD Phenom, ARM, etc) with more suitable
- # float comparison - https://gitlab.freedesktop.org/gstreamer/orc/issues/18
- "${FILESDIR}"/${PV}-test-rounding.patch
-)
-
-src_prepare() {
- default
-
- # Do not build examples
- sed -e '/SUBDIRS/ s:examples::' \
- -i Makefile.am Makefile.in || die
-}
-
-multilib_src_configure() {
- # any optimisation on PPC/Darwin yields in a complaint from the assembler
- # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
- # the same for Intel/Darwin, although the error message there is different
- # but along the same lines
- [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
-
- # FIXME: handle backends per arch? What about cross-compiling for the other arches?
- ECONF_SOURCE="${S}" econf \
- --disable-gtk-doc \
- --enable-backend=all \
- $(use_enable static-libs static)
- # TODO: bug #645232 - Not ready for this yet, as it installs some headers to live and gst-plugins-base:0.10 includes some
- # Additionally it doesn't seem good that FEATURES=test would change what files are installed (headers + orctest.so + orc-bugreport)
- # $(use_enable test tests)
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files --all
-
- if use pax_kernel; then
- pax-mark m "${ED}"usr/bin/orc-bugreport
- pax-mark m "${ED}"usr/bin/orcc
- pax-mark m "${ED}"usr/$(get_libdir)/liborc*.so*
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.c,*.orc}
- fi
-}
-
-pkg_postinst() {
- if use pax_kernel; then
- ewarn "Please run \"revdep-pax\" after installation".
- ewarn "It's provided by sys-apps/elfix."
- fi
-}